Bug 89034 - Wireless interface missing when redhat-control-network is run as ordinary user
Wireless interface missing when redhat-control-network is run as ordinary user
Status: CLOSED DUPLICATE of bug 88568
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-16 15:12 EDT by David Eriksson
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Eriksson 2003-04-16 15:12:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
(First, redhat-control-network wouldn't run on my RedHat 9 system unless I
commented out the  "from netconfpkg.gui.exception import handleException" line
on row 54 in neat-control.py but that's a minor issue.)

I have configured two network interfaces with redhat-config-network:

http://www.2good.nu/tmp/Screenshot-Redhat-config-network-gui.png

Both network interfaces has the option "Allow all users to enable and disable
the device" checked. All other interface options are left as default or changing
them makes no difference.

When I run redhat-control-network as root I see them both:

http://www.2good.nu/tmp/Screenshot-Redhat-control-network-root.png

When I run redhat-control-network as my ordinary user, I don't see my wireless
interface:

http://www.2good.nu/tmp/Screenshot-Redhat-control-network-user.png

I had a look at the ifcfg files and noticed that
/etc/sysconfig/network-scripts/ifcfg-eth0 has mode 644 but
/etc/sysconfig/network-scripts/ifcfg-eth1 (wireless) has mode 600. Changing the
latter mode to 644 made everything work as I expected.

The following modification
/usr/share/redhat-config-network/netconfpkg/NCWireless.py fixes the problem:

# diff NCWireless.py.original NCWireless.py
78,79c78,79
<         conf.oldmode = 0644
<         conf.chmod(0644)
---
>         conf.oldmode = 0600
>         conf.chmod(0600)


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.3-3, rhpl-0.95-1 (downloaded from
ftp://people.redhat.com/harald/redhat-config-network/1.2.3-RH9)

How reproducible:
Always

Steps to Reproduce:
This assumes that a wireless interface is already configured.

1) chmod 644 \
/etc/sysconfig/network-scripts/ifcfg-eth* \
/etc/sysconfig/networking/profiles/default/ifcfg-eth* \
/etc/sysconfig/networking/devices/ifcfg-eth*

2) redhat-config-network:

2.1) Uncheck the wireless interface

2.2) Save

2.3) Check the wireless interface

2.4) Save and quit


Actual Results:  ls -l /etc/sysconfig/network-scripts/ifcfg-eth* 
/etc/sysconfig/networking/profiles/default/ifcfg-eth*
/etc/sysconfig/networking/devices/ifcfg-eth*

-rw-r--r--    3 root     root          203 Apr 16 20:58
/etc/sysconfig/networking/devices/ifcfg-eth0
-rw-------    3 root     root          303 Apr 16 20:58
/etc/sysconfig/networking/devices/ifcfg-eth1
-rw-r--r--    3 root     root          203 Apr 16 20:58
/etc/sysconfig/networking/profiles/default/ifcfg-eth0
-rw-------    3 root     root          303 Apr 16 20:58
/etc/sysconfig/networking/profiles/default/ifcfg-eth1
-rw-r--r--    3 root     root          203 Apr 16 20:58
/etc/sysconfig/network-scripts/ifcfg-eth0
-rw-------    3 root     root          303 Apr 16 20:58
/etc/sysconfig/network-scripts/ifcfg-eth1
Comment 1 Harald Hoyer 2003-04-17 06:43:45 EDT

*** This bug has been marked as a duplicate of 88568 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.