Bug 890343 - Cant sign-in with # or < character is in initial password (root and user)
Cant sign-in with # or < character is in initial password (root and user)
Status: CLOSED DUPLICATE of bug 892097
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
18
i686 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-26 09:44 EST by Leslie Satenstein
Modified: 2013-01-07 06:22 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 06:22:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
00-anaconda-anaconda-keyboard.conf (203 bytes, text/plain)
2013-01-02 13:09 EST, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2012-12-26 09:44:07 EST
Description of problem:

   When completing a DVD installation where the Canadian French keyboard is   selected as first, I do setup the user, I do provide a password, but then after first boot or equivalent, I cannot log into the system with that password. 

Version-Release number of selected component (if applicable):

This is Fedora RC? TC3 that is suppposedly going for Jan 8 install.

How reproducible:



Steps to Reproduce:
1. In the anacondo installation process for Fedora 18 tc3 I select language English.
2. I select Gnome and all the desired options
3. I select keyboard. I first delete the English(US) Keyboard and replace it with the ca(fr).  Testing the characters entered confirms good keyboard choice.
4. I add back the English(US) keyboard as the second choice and select menu as the keyboard selecting option
5. I assign root a password, making sure it has only alphabetic keys. The key locations are in identical key positions for both keyboards selected. I assign a password with only 9 different alphabetic characters, as I want to be certain to log into root on a reboot. (This pwd will be changed later to something more secure)
6. Before triggering anaconda to begin the installation, I confirm via the anaconda gui interface that the keyboard  is functioning as Canadian French. 
7 After anaconda is completed, I remove the DVD and reboot.
8. I am asked to create a user. I create my administrator user and I check that the user is the administrator.
9. For this user, I use a password that is as follows  #whatever001. 
10. When firstboot completes, I am presented with a Fedora 18 logon screen
11 I select myself (there is no other) and I attempt to log on using the password #whatever001.       
12. I confirm that the keyboard layout for selecting the password is ca(fr).
  
Actual results:

Password presented #whatever001 is refused. I try to re -enter it with the English(US) layout and I try again with the CA(fr) and both are refused. 


Expected results:
  
    To be able to log on to Fedora.

Additional info:

I am able to enter virtual console mode using my restricted password. 
The virtual console keyboard layout is English(us). It is not what I want. 
I am not able to log into Fedora for the administrator user using password #whatever001

Because I used only alphabetics for the root password, I succeed with this password. 

I issue the passwd command for the user and again enter #whatever001
After this I am able to log into Fedora 18 a user.  

My only keyboard on the system is the Canadian French.  The virtual console has it as Englsh (US).

By the way, I tried several installation tests with the checkbox (language selection) and without. The results are wrong each way.

Anaconda should respect the keyboard assignment rules for virtual console that were in place from Fedora 6 through Fedora 17.  

Further note: The ca(FR) GRAPHICAL LAYOUT IS WRONG. it is not showing the « and »  as an addditional key to the left of the letter z key.
Comment 1 Leslie Satenstein 2012-12-26 09:46:11 EST
If you have a TC4 or other as DVD, I will download and test. I am not building up Fedora 18 TC3 until go-live, so that I can continue testing for you.
Comment 2 Vratislav Podzimek 2013-01-02 04:25:14 EST
When firstboot is run (screens where you create a new user for the system), do you have right layout set? You can try that by typing to some entry with visible characters. Could you please try the same in the GDM screen? (by clicking on "Not listed?" and typing to the username box). And could you please attach the /etc/X11/xorg.conf.d/00-anaconda.conf file from the installed system?

I believe that file contains right configuration. The question is whether firstboot and GDM use this configuration.
Comment 3 Leslie Satenstein 2013-01-02 11:32:46 EST
I will respond later this AM (1.5 hrs from now. Going to do fresh installation (again)
Comment 4 Leslie Satenstein 2013-01-02 13:09:01 EST
Created attachment 671617 [details]
00-anaconda-anaconda-keyboard.conf

The requested copy of X11 file
Comment 5 Leslie Satenstein 2013-01-02 13:11:01 EST
The GDM Signon screen shows Canadian French Keyboad (# in the right place).
The xorg file is attached and is posted below
 


 #This file was generated by the Anaconda installer
Section "InputClass"
    Identifier    "anaconda-keyboard"
    MatchIsKeyboard    "on"
    Option    "XkbLayout"    "ca,us"
    Option    "XkbOptions"    "grp:menu_toggle"
EndSection


I will temporarily change layout to ca(fr),us
and let you know the answer<

  Option    "XkbLayout"    "ca(fr),us"
====
Change made no difference.
====
Here is some additional information to help

After creating the user, I logged on in GUI Gnome as root and tested the keys by creating a second new user. The password for this user is correct this time as it corresponds to what I entered
It is recognized correctly by the logon screen. 

I believe the problem may be with firstboot.

The Virtual console keyboard is still wrong. It is showing up as US English.
===
 tested with   ca,us and ca(fr),us with no difference. The virtual console is still wrong.
Here is something else I discovered that may be important


I saw an extra character before and after  the  '00-anaconda-keyboard.conf'
 
In virtual console each appears as a single white square. 
with rm -i  from the Gnome Virtual console the file name is `00-anaconda-keyboard.conf´    with `and´ surrounding.
The virtual console (ctl-alt-f2) does not display these two characters but the gnome console does.
====
Comment 6 Leslie Satenstein 2013-01-02 18:53:51 EST
With some playing around, I discovered that firstboot used the English USA layout for the password. When I was entering #, it really was a back quote? `  

With the Canadian French keyboard the ` is entered by typing the character twice.

the ` is used for creating accented letters  such as à è ì ò ù
Comment 7 Vratislav Podzimek 2013-01-03 05:26:49 EST
The VConsole keymap is configured by the /etc/vconsole.conf file. Changing 'us' to 'fr' there should work (see bug #889562 for some more info).

The X layouts are configured by the /etc/X11/xorg.conf.d/* files and the attached 00-anaconda-keyboard.conf file looks as expected (note that the name/id of the "French (Canadian)" layout is 'ca' not 'ca(fr)' or anything else). It reflects the fact, that two layouts where configured during installation ("French (Canadian)" and "English (United States)").

From comment #6 it seems that the problem lies in firstboot. It probably sets keyboard configuration on its own behalf instead of letting X server control keyboard layouts according to its configuration in /etc/X11/xorg.conf.d/* files.
Comment 8 Vratislav Podzimek 2013-01-03 06:18:31 EST
(In reply to comment #7) 
> From comment #6 it seems that the problem lies in firstboot. It probably
> sets keyboard configuration on its own behalf instead of letting X server
> control keyboard layouts according to its configuration in
> /etc/X11/xorg.conf.d/* files.
Indeed, reassigning to firstboot.
Comment 9 Leslie Satenstein 2013-01-03 07:53:37 EST
Good Morning Vratislav

The problem is with firstboot, but is also with anaconda.
Let me explain why I do step 3 above.

When I begin the installation, by default the English US keyboard is selected.
I then add the Canadian French keyboard, and move it to first place, in front of the English US Keyboard

Testing the characters with the changed position of CA first, after all efforts to force anaconda to recognize CA as first fails.
The only way to get CA recognized is to delete the English US keyboard and to remain only with the CA French.  Now when I test I get the ###. After so doing, I add back the English US.

So in part, firstboot is responsible, and also anaconda.
From the Buglist, this problem and a similar one for Japanese is now recognized as a bugstopper.  

Thank you for your efforts.
Comment 10 Leslie Satenstein 2013-01-03 07:55:36 EST
When I686 is debugged, I will retest with amd-64 (I have Intel dual core systems), one system for 32bit, one for 64bit. I do not test with VMs.
Comment 11 Martin Sivák 2013-01-03 09:26:06 EST
Firstboot uses system-config-keyboard to load and activate keyboard layout. I can kill those three lines if necessary. It should not cause any more harm (I think) if the keyboard is properly specified in Xorg configuration.
Comment 12 Leslie Satenstein 2013-01-04 11:41:29 EST
Today I tested with TC4 and produced a full log of my activities. 

I am attaching this log (libreoffice writer format) to this bug
Comment 13 Leslie Satenstein 2013-01-04 12:00:42 EST
TC4 Testing   A formatted document does not appear to be elegible for upload.
Here is the text equivalent


Setting time zone
Montreal  (GMT -5) OK

Keyboard Layout
Added French(French(Canada)) and moved it to first place and clicked on it to select it as the default.  Graphical Layout is  incorrect , missing key to left of Z key.  Selecting French Keyboard does not change default settings.  Still producing ` in place of #     NOK

Keyboard Layout
Delete English(English (US)) and reinstall as second keyboard.  Now default keys are matching French Layout. Graphical Layout missing key to left of Z key.
NOK

Keyboard Layout
Menu Select for switch Selected  OK

Network Setup
Wireless settings      OK

Local Disk Selection
Found my 160 gig free space. I selected BTFRS  OK

Installation Source
Shows DVD    OK

HostName
No request    NOK

Root Password
OK Gives warning if not strong enough  OK

Installation is running
Took defaults for Gnome. There was no yellow triangle asking for review of Gnome Input. One should be able to select more than one GUI interface.  Ex. Gnome, KDE,    NOK

Installation is running
1190 items, Gnome default taken.
It appears that each module is checked against a host file for version status. Is the later version supposed to be downloaded?    OK

Reboot
Fedora 17 on the disks was not detected. Anaconda bug  NOK

FirstBoot
The last paragraph makes understanding the license as an optional concern.
Should there be a stronger legal statement?   OK/NOK

Entering Create User
The wrong keyboard layout is in effect. It appears to be English US.  It should be French(French Canada))
NB. The ` character will be presented in place of #.  With the French Keyboard, ` will require entering it twice.
User added to administrative group. NOK

Date and Time
Accepted NTP servers, Found Speedup option clicked. Did not want Use Local
OK

Logon
Logon worked with wrong character Because English US was in effect. Currently. The keyboard in effect for GDM is Canada(French). Verified at logon 
OK / NOK

After Logon
The Gnome panel does not show logoff as an option, Only shows Notifications (on/off), System Settings, Lock and Power Off, and Install Updates and restart. 
Will do the IUR   OK/NOK

After Logon
InstalL Updates and Restart jumps directly to Restart.  Restart permitted,
NOK

In Restart
Some updates occurred, Restarting (only user is me, and root OK

Logging in after IUR
Message about critical updates installed OK

Add New User
The User Name and Full Name fields are reverse order to what is presented in First Boot. It should be revised here, not in First Boot   NOK

After Creating 2nd User
Logoff option appears    OK

Software update and Selection
Clicked on Menu to Check for Updates.  All software is Up to Date OK

Vconsole
English USA. It should be French Canada   NOK

As Root
grub2-mkconfig to update grub.cfg so as to have return of missing distributions. After new grub.cfg reboot to have Fedora 17 distribution back in the list.    NOK
Comment 14 Vratislav Podzimek 2013-01-07 06:22:49 EST

*** This bug has been marked as a duplicate of bug 892097 ***

Note You need to log in before you can comment on or make changes to this bug.