Bug 890500 - Remote-viewer will create only 1 or 2 consoles if client machine has more than 3 physical monitors
Remote-viewer will create only 1 or 2 consoles if client machine has more tha...
Status: CLOSED DUPLICATE of bug 1076728
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-27 05:53 EST by Geyang Kong
Modified: 2014-06-18 05:16 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-20 14:59:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file with SPICE_DEBUG=1 (24.04 KB, text/plain)
2013-05-20 22:10 EDT, Geyang Kong
no flags Details
spice vdagent log (1.20 KB, text/plain)
2013-05-21 22:53 EDT, Geyang Kong
no flags Details
Xort.0.log (100.59 KB, image/x-pcx)
2013-06-26 02:37 EDT, CongDong
no flags Details

  None (edit)
Description Geyang Kong 2012-12-27 05:53:36 EST
Description of problem:
  Remote-viewer will create only 1 or 2 consoles if client machine has more than 3 physical monitors

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-18.el6.x86_64
spice-server-0.12.0-10.el6.x86_64
spice-glib-0.14-6.el6.x86_64
spice-gtk-python-0.14-6.el6.x86_64
spice-gtk-tools-0.14-6.el6.x86_64
spice-gtk-0.14-6.el6.x86_64
spice-vdagent-0.12.0-3.el6.x86_64

Reproduce steps:
1. Install a RHEL6.4 host and a RHEL6.4 guest with gnome.
2. Make sure guest has spice+qxl video devices and spicevmc channel exists.
3. Upgrade spice packages in both host and guest.
4. Have at least 3 physical monitors plugged on the host.
5. remote-viewer spice://127.0.0.1:5900 --full-screen=auto-conf

Actual results:
1. After step 5, remote-viewer only creates 1(sometimes 2) form.

Expected results:
1. There should be 3 or 4 forms(same as number of physical monitors), in full-screen mode, displayed in each of physical monitor

Additional info:
1. If host has 2 physical monitors, this command will work well
Comment 1 Marc-Andre Lureau 2013-05-09 19:21:52 EDT
more likely a vdagent or xf86-qxl issue.

Reporter, can you attach the SPICE_DEBUG=1 log when you connect to guest? thanks
Comment 2 Geyang Kong 2013-05-20 22:10:25 EDT
Created attachment 750790 [details]
Log file with SPICE_DEBUG=1

I have attached log files with SPICE_DEBUG=1 based on following build:
virt-viewer-0.5.2-18.el6_4.2.x86_64
spice-vdagent-0.12.0-4.el6_4.1.x86_64
spice-gtk-0.14-7.el6.x86_64
spice-gtk-python-0.14-7.el6.x86_64
spice-server-0.12.0-12.el6.x86_64
spice-glib-0.14-7.el6.x86_64
spice-xpi-2.7-22.el6.x86_64
Comment 3 Marc-Andre Lureau 2013-05-21 08:25:42 EDT
The guest monitor config doesn't match request:

(remote-viewer:4263): GSpice-DEBUG: channel-main.c:969 main-1:0: monitor config: #0 1280x1024+0+0 @ 32 bpp
(remote-viewer:4263): GSpice-DEBUG: channel-main.c:969 main-1:0: monitor config: #1 1680x1050+1280+0 @ 32 bpp
(remote-viewer:4263): GSpice-DEBUG: channel-main.c:969 main-1:0: monitor config: #2 1280x1024+2960+0 @ 32 bpp
(remote-viewer:4263): GSpice-DEBUG: channel-main.c:969 main-1:0: monitor config: #3 1680x1050+4240+0 @ 32 bpp

(remote-viewer:4263): GSpice-DEBUG: channel-display.c:1520 display-2:0: monitors config: n: 3/4
(remote-viewer:4263): GSpice-DEBUG: channel-display.c:1540 display-2:0: monitor id: 0, surface id: 0, +0+0-1280x1024
(remote-viewer:4263): GSpice-DEBUG: channel-display.c:1540 display-2:0: monitor id: 2, surface id: 0, +1280+0-2560x1600
(remote-viewer:4263): GSpice-DEBUG: channel-display.c:1540 display-2:0: monitor id: 3, surface id: 0, +3840+0-2560x1600

The guest resize seems to have failed, the pimary is only 1280x768, so none of the extra monitor fit (monitor area is not intersecting)

Can you please attach the vdagent log?

thanks
Comment 4 Geyang Kong 2013-05-21 22:53:43 EDT
Created attachment 751472 [details]
spice vdagent log
Comment 5 Hans de Goede 2013-05-22 03:44:59 EDT
Hi,

(In reply to Geyang Kong from comment #4)
> Created attachment 751472 [details]
> spice vdagent log

Looking at the log:
May 21 22:51:09.170759 spice-vdagentd: warning: Client has 4 monitors, but only 1 qxl devices found

You seem to be using an old agent, as the latest agent (spice-vdagent-0.12.0-4.el6_4.1) no longer generates these messages. Please make sure your guest has the latest version of the agent and of xorg-x11-drv-qxl.

Regards,

Hans
Comment 6 Geyang Kong 2013-05-22 05:39:02 EDT
I tried it with spice-vdagent-0.12.0-4.el6_4.1 and xorg-x11-drv-qxl-0.1.0-4.el6, this bug is still there, what I got from the spice-vdagent.log is like following:

May 22 05:24:29.192847 spice-vdagent[2322]: err: XRRSetScreenSize failed, not enough mem?
May 22 05:24:29.192861 spice-vdagent[2322]: warning: Restoring previous config
May 22 05:24:29.231206 spice-vdagent[2322]: warning: Ignoring previous failed client monitor config
May 22 05:24:29.231564 spice-vdagent[2322]: warning: Ignoring previous failed client monitor config
May 22 05:24:29.231922 spice-vdagent[2322]: warning: Ignoring previous failed client monitor config
May 22 05:24:29.232308 spice-vdagent[2322]: warning: Ignoring previous failed client monitor config
May 22 05:24:29.232643 spice-vdagent[2322]: warning: Ignoring previous failed client monitor config
May 22 05:24:29.232999 spice-vdagent[2322]: warning: Ignoring previous failed client monitor config
May 22 05:24:38.608111 spice-vdagent[2322]: err: client sent config with all monitors disabled

I tried to edit ram and vram of QXL through virsh command, set them as 256MB, but nothing changed.
Comment 7 Hans de Goede 2013-06-24 03:31:56 EDT
(In reply to Geyang Kong from comment #6)
> I tried it with spice-vdagent-0.12.0-4.el6_4.1 and
> xorg-x11-drv-qxl-0.1.0-4.el6, this bug is still there, what I got from the
> spice-vdagent.log is like following:
> 
> May 22 05:24:29.192847 spice-vdagent[2322]: err: XRRSetScreenSize failed,
> not enough mem?

As the log message already says, the problem is that XRRSetScreenSize failed, usually this is caused by not enough videoram, but you say you've already tried raising that. Can you please attach /var/log/Xorg.0.log from inside the guest, after a failed attempt ?
Comment 8 CongDong 2013-06-26 02:37:45 EDT
Created attachment 765415 [details]
Xort.0.log
Comment 9 Hans de Goede 2013-06-26 04:14:08 EDT
Thanks for the log, interesting part of the log:

[   318.864] (II) qxl(0): qxl_xf86crtc_resize: Placeholder resize 5920x1050
[   318.864] resizing primary to 5920x1050
[   318.864] resizing surface0 to 24864000
[   318.864] resizing surface0 compiled out
[   318.864] not resizing primary to virtual, leaving old virtual

So this seems to be an xorg-x11-drv-qxl issue, changing component.
Comment 12 Søren Sandmann Pedersen 2014-05-15 10:53:01 EDT
If anyone is still paying attention to this bug, please test this build of the QXL driver:

 http://brewweb.devel.redhat.com/brew/taskinfo?taskID=7457635
Comment 13 Søren Sandmann Pedersen 2014-05-20 14:59:15 EDT

*** This bug has been marked as a duplicate of bug 1076728 ***

Note You need to log in before you can comment on or make changes to this bug.