Bug 890534 - [abrt] evolution-3.4.4-2.fc17: g_type_check_instance_cast: Process /usr/libexec/evolution/3.4/evolution-alarm-notify was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.4-2.fc17: g_type_check_instance_cast: Process /usr/libex...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:6ecc75d43fda38dac9c9c8553a9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-27 10:14 EST by Koby Hershkovitz
Modified: 2013-01-07 06:53 EST (History)
3 users (show)

See Also:
Fixed In Version: evolution-3.6.2-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 06:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.99 KB, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: environ (1.60 KB, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: backtrace (41.38 KB, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: cgroup (128 bytes, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: smolt_data (3.64 KB, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: executable (49 bytes, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: maps (60.54 KB, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: dso_list (12.59 KB, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: var_log_messages (192 bytes, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details
File: open_fds (714 bytes, text/plain)
2012-12-27 10:14 EST, Koby Hershkovitz
no flags Details

  None (edit)
Description Koby Hershkovitz 2012-12-27 10:14:01 EST
Description of problem:
refreshed ews based account

Version-Release number of selected component:
evolution-3.4.4-2.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/libexec/evolution/3.4/evolution-alarm-notify
crash_function: g_type_check_instance_cast
kernel:         3.6.10-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 g_type_check_instance_cast at gtype.c:3999
: #1 alarm_notify_list_changed_cb at alarm-notify.c:154
: #2 _g_closure_invoke_va at gclosure.c:840
: #5 group_changed_callback at e-source-list.c:221
: #6 _g_closure_invoke_va at gclosure.c:840
: #12 e_source_set_property at e-source.c:1184
: #13 config_data_set_last_notification_time at config-data.c:270
: #14 alarm_trigger_cb at alarm-queue.c:464
: #15 alarm_ready_cb at alarm.c:110
: #20 g_main_context_iteration at gmain.c:3207
Comment 1 Koby Hershkovitz 2012-12-27 10:14:04 EST
Created attachment 669623 [details]
File: core_backtrace
Comment 2 Koby Hershkovitz 2012-12-27 10:14:06 EST
Created attachment 669624 [details]
File: environ
Comment 3 Koby Hershkovitz 2012-12-27 10:14:09 EST
Created attachment 669625 [details]
File: backtrace
Comment 4 Koby Hershkovitz 2012-12-27 10:14:11 EST
Created attachment 669626 [details]
File: limits
Comment 5 Koby Hershkovitz 2012-12-27 10:14:13 EST
Created attachment 669627 [details]
File: cgroup
Comment 6 Koby Hershkovitz 2012-12-27 10:14:15 EST
Created attachment 669628 [details]
File: smolt_data
Comment 7 Koby Hershkovitz 2012-12-27 10:14:17 EST
Created attachment 669629 [details]
File: executable
Comment 8 Koby Hershkovitz 2012-12-27 10:14:20 EST
Created attachment 669630 [details]
File: maps
Comment 9 Koby Hershkovitz 2012-12-27 10:14:22 EST
Created attachment 669631 [details]
File: dso_list
Comment 10 Koby Hershkovitz 2012-12-27 10:14:24 EST
Created attachment 669632 [details]
File: proc_pid_status
Comment 11 Koby Hershkovitz 2012-12-27 10:14:26 EST
Created attachment 669633 [details]
File: var_log_messages
Comment 12 Koby Hershkovitz 2012-12-27 10:14:29 EST
Created attachment 669634 [details]
File: open_fds
Comment 13 Milan Crha 2013-01-07 06:53:44 EST
Thanks for a bug report. The code in question changed in current upstream stable, which is 3.6.2. It is part of the upcoming Fedora 18, thus I'd suggest to re-try with it, because many good fixes landed into 3.6.x, both on evolution and evolution-ews side. Please retest with it when you get to Fedora 18. Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.