Bug 890809 - quantum net-create name option is not working currectly when more than one option is used
quantum net-create name option is not working currectly when more than one op...
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutronclient (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
low Severity low
: ---
: 5.0 (RHEL 7)
Assigned To: Jakub Ruzicka
Ofer Blaut
: Improvement, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-30 05:45 EST by Ofer Blaut
Modified: 2016-04-26 10:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-neutronclient-2.3.4-1.el6ost.noarch
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-05 00:38:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1326633 None None None Never

  None (edit)
Description Ofer Blaut 2012-12-30 05:45:39 EST
Description of problem:

quantum net-create name option is not working currectly when more than one option

See attached example 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create network with only tenant ID and name - it works , 
if using --name  < name > it will fails
( quantum net-create --tenant-id < ID > <network name > )

2. create network with tenant ID , shared option & name - it will fail 

quantum net-create --tenant-id < ID > --shared True  <network name >

3. create network with tenant ID , shared option & -- name < name> - will pass

quantum net-create --tenant-id < ID > --shared True  --name <network name >
  
Actual results:

According to CLI help 

--name should not be used 

Expected results:


Additional info:
Comment 4 Jakub Ruzicka 2014-05-06 14:27:44 EDT
This WFM in python-neutronclient-2.3.4.
Comment 5 Ofer Blaut 2014-05-07 02:37:05 EDT
Hi Kuba 

still not work

[root@puma04 ~(keystone_admin)]# neutron net-create --tenant-id e91cdd9e867b49059cc79898413fd0ee --shared True --name ofer1
Created a new network:
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | 18c78edf-7508-4756-bd5d-3757f544eb2f |
| name                      | ofer1                                |
| provider:network_type     | vxlan                                |
| provider:physical_network |                                      |
| provider:segmentation_id  | 3                                    |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   |                                      |
| tenant_id                 | e91cdd9e867b49059cc79898413fd0ee     |
+---------------------------+--------------------------------------+
[root@puma04 ~(keystone_admin)]# neutron net-create --tenant-id e91cdd9e867b49059cc79898413fd0ee --shared True ofer2
Invalid values_specs ofer2
[root@puma04 ~(keystone_admin)]# 


since --name is not a must , ofer2 should work 


python-neutronclient-2.3.4-1.el6ost.noarch
Comment 6 Jakub Ruzicka 2014-05-12 08:58:15 EDT
Oh, I see, you're right.

So this is IMHO more of a cosmetic fix - there is a way to do what you need, it just could be smoother.

Please report upstream and link the external tracker:
https://bugs.launchpad.net/python-neutronclient/+filebug
Comment 7 Ofer Blaut 2014-06-05 00:38:57 EDT
opened upstream

Note You need to log in before you can comment on or make changes to this bug.