This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 890966 - nova help of add-fixed-ip command is not correct
nova help of add-fixed-ip command is not correct
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
low Severity low
: snapshot5
: 2.1
Assigned To: Jakub Ruzicka
Ofer Blaut
: Triaged, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-31 09:08 EST by Ofer Blaut
Modified: 2016-04-26 10:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-novaclient-2.10.0-5.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-04 13:58:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ofer Blaut 2012-12-31 09:08:42 EST
Description of problem:

 nova help of add-fixed-ip  command is not correct 

The current help is " Add new IP address to network."
while is should be  " Add new IP address to Instance."

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.nova help add-fixed-ip 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Nikola Dipanov 2013-01-04 11:12:11 EST
I've posted a patch to the upstream python-novaclient: https://review.openstack.org/18963, I will move the bug to post as soon as (if) the patch gets accepted upstream.
Comment 3 Nikola Dipanov 2013-01-28 07:11:05 EST
Upstream change has been merged so we may proceed with the backport.
Comment 6 Ofer Blaut 2013-03-18 09:52:41 EDT
Tested 
python-novaclient-2.10.0-7.el6ost.noarch


[root@puma04 ~(keystone_admin)]$ nova help  add-fixed-ip
usage: nova add-fixed-ip <server> <network-id>

Add new IP address on a network to server.

Positional arguments:
  <server>      Name or ID of server.
  <network-id>  Network ID.
Comment 8 errata-xmlrpc 2013-04-04 13:58:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0706.html

Note You need to log in before you can comment on or make changes to this bug.