Bug 891062 - [RFE] Horizon doesn't support different network providers types when creating new network
[RFE] Horizon doesn't support different network providers types when creating...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
low Severity low
: Upstream M3
: 6.0 (Juno)
Assigned To: Julie Pichon
Itzik Brown
https://blueprints.launchpad.net/hori...
upstream_milestone_juno-3 upstream_st...
: FutureFeature
Depends On: 988517 988518 1188069
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-01 08:45 EST by Ofer Blaut
Modified: 2016-04-27 00:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-django-horizon-2014.2-4.el7ost
Doc Type: Enhancement
Doc Text:
An admin user can now specify the Provider network type (the physical mechanism by which the virtual network is implemented), when creating a new network. Previously, the dashboard (horizon) defaulted to the 'Local' provider network type, and it was not possible to select another type. The types 'Flat', 'VLAN', 'GRE', and 'VXLAN', and 'Local' can now be selected in the new 'Provider Network Type' drop-down field. Depending on the type, a segmentation ID, tunnel ID, or physical network name must be additionally specified.
Story Points: ---
Clone Of:
: 1188069 (view as bug list)
Environment:
Last Closed: 2015-02-09 09:53:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ofer Blaut 2013-01-01 08:45:41 EST
Description of problem:

There are few different network providers types when creating new network using quantum.

Horizon doesn't support these network providers types when creating new network,

Default network provider used is Local. 

Horizon doesn't show any network provider information on existing network 

http://docs.openstack.org/folsom/openstack-network/admin/content/provider_api_workflow.html


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Nuno Santos 2013-05-14 11:48:05 EDT
Upstream blueprint: https://blueprints.launchpad.net/horizon/+spec/quantum-network-provider-types
Comment 3 Scott Lewis 2013-08-01 13:35:51 EDT
Matched priority to upstream.
Comment 5 Stephen Gordon 2014-01-24 11:32:01 EST
Updating based on BP milesone.
Comment 6 Stephen Gordon 2014-02-19 14:36:13 EST
Updating based on BP milestone
Comment 8 Julie Pichon 2014-11-20 07:37:11 EST
How to test:
------------

Neutron should have the provider network extension configured (you can check with `neutron net-list`, the extension name is "provider").

1. Log in as admin
2. Go to Admin -> Systems -> Create network
3. A new "Provider Type" option should be available

Because the provider type depends on the plugin but there is no way to determine which types are available from the APIs, Horizon shows all possible options and is expected to fail gracefully and show an error message for the ones not actually handled by the backend.

However, a setting was additionally implemented for deployer to manually hide the unneeded options if necessary. In /etc/openstack-dashboar/local_settings

OPENSTACK_NEUTRON_NETWORK = {
   # <all the usual options>
   'supported_provider_types': ['local', 'flat', 'gre'] # Example values
   'segmentation_id_range': {'vlan': [1024, 2048], 'gre': [4094, 65536]} # Example values
}

(See http://docs.openstack.org/developer/horizon/topics/settings.html#openstack-neutron-network for more information on these 2 settings)
Comment 10 Itzik Brown 2014-12-15 05:11:27 EST
Tested openstack-dashboard-2014.2.1-2.el7ost.noarch
Comment 12 errata-xmlrpc 2015-02-09 09:53:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0154.html

Note You need to log in before you can comment on or make changes to this bug.