Bug 891309 - Horizon floating ip quote is not taken from Quantum conf file but from Nova
Horizon floating ip quote is not taken from Quantum conf file but from Nova
Status: CLOSED DUPLICATE of bug 970996
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity medium
: beta
: 4.0
Assigned To: Julie Pichon
Ami Jeain
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2013-01-02 09:44 EST by Ofer Blaut
Modified: 2016-04-26 10:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-03 11:16:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1109140 None None None Never

  None (edit)
Description Ofer Blaut 2013-01-02 09:44:19 EST
Description of problem:

Horizon - displays floating ip quote , 

floating ip quote is not taken from Quantum but conf file from Nova

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. don't configure any floating ip quote on quantum or stop quantum server 
2. confiugre  /etc/quantum/quantum.conf with quota_floatingip = 75 & restart quantum server 

3.check horizon quote page 
Actual results:

floatingip = 25 

Expected results:

Additional info:
Comment 2 Julie Pichon 2013-02-18 17:52:20 EST
In Grizzly, the Quota architecture was enhanced to better handle optional/extra services like Cinder and Quantum (although Quantum hasn't been explicitly added yet). However the scope of the patches to do this is such that it's unlikely to be backported to Folsom, as explained in comment #4 for the Cinder equivalent of that bug upstream - https://bugs.launchpad.net/horizon/+bug/1095876. Moved to RHOS 3.0.
Comment 3 Julie Pichon 2013-09-03 11:16:22 EDT
Marking this as a duplicate of bug 970996 as it appears to be similar, and most of the information is now over there.

*** This bug has been marked as a duplicate of bug 970996 ***

Note You need to log in before you can comment on or make changes to this bug.