Bug 891394 - [gu] deprecated modules should not be translated from msgid to msgstr
[gu] deprecated modules should not be translated from msgid to msgstr
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481 895654
  Show dependency treegraph
 
Reported: 2013-01-02 14:36 EST by John Sefler
Modified: 2013-02-21 04:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:06:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-01-02 14:36:16 EST
Description of problem:
When a word is actually referring to a command line module, it should not be translated.

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64

How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/gu/LC_MESSAGES/rhsm.mo | grep -i -A1 -- "deprecated, see"
msgid "Deprecated, see --auto-attach"
msgstr "અપ્રચલિત, --auto-attach જુઓ"
--
msgid "Deprecated, see attach"
msgstr "અપ્રચલિત, જોડાણ જુઓ"
--
msgid "Deprecated, see remove"
msgstr "અપ્રચલિત, દૂર કરવાનું જુઓ"
--
msgid "deprecated, see auto-attach-interval"
msgstr "અપ્રચલિત, auto-attach-interval જુઓ"
[root@jsefler-6 ~]# 

  
Actual results:
above

Expected results:
"attach" and "remove" should not be translated

Additional info:
Comment 2 Ankit Patel 2013-01-08 00:45:04 EST
Corrected and submitted through Zanata.

Thanks!
Ankit
Comment 5 John Sefler 2013-01-08 13:45:56 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.20-1.el6.x86_64

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/gu/LC_MESSAGES/rhsm.mo | grep -i -A1 -- "deprecated, see"
msgid "Deprecated, see --auto-attach"
msgstr "અપ્રચલિત, --auto-attach જુઓ"
--
msgid "Deprecated, see attach"
msgstr "અપ્રચલિત, attach જુઓ"
--
msgid "Deprecated, see remove"
msgstr "અપ્રચલિત, remove જુઓ"
--
msgid "deprecated, see auto-attach-interval"
msgstr "અપ્રચલિત, auto-attach-interval જુઓ"

VERIFIED
Comment 7 errata-xmlrpc 2013-02-21 04:06:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.