Bug 891408 - [RFE] If the compute node running a VM dies, the state in the database remains Active:Running indefinitely
[RFE] If the compute node running a VM dies, the state in the database remain...
Status: CLOSED DUPLICATE of bug 1178665
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Nikola Dipanov
yeylon@redhat.com
: FutureFeature, Improvement, MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-02 15:51 EST by Perry Myers
Modified: 2016-04-26 15:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 15:49:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1072734 None None None Never

  None (edit)
Description Perry Myers 2013-01-02 15:51:14 EST
Description of problem:
If you run a VM on a compute node, and that compute node dies (hardware failure or just a simple shutdown) the state of the running VM is never updated in the database.  It'll remain as Active:Running indefinitely and it is left to the administrator of the cloud to clean up the state manually.  From a user PoV this is not ideal.

If the compute node comes back online, then it should update the state periodically to reconcile the actual state with the db state.  But if that compute node is dead for a long time, this state could remain out of sync for a while.

Need some sort of process that knows when to set the status for a VM to be stale/unknown.
Comment 1 Martin Magr 2013-01-15 10:05:35 EST
Setting as RFE as it seems that this issue is known to upstream [1]. So we should either wait till somebody will implement it or implement it ourselves.

[1] - https://bugs.launchpad.net/nova/+bug/1072734
Comment 6 Stephen Gordon 2016-01-28 15:49:15 EST

*** This bug has been marked as a duplicate of bug 1178665 ***

Note You need to log in before you can comment on or make changes to this bug.