Bug 89158 - Installer dies and hangs at various packages
Installer dies and hangs at various packages
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-18 14:25 EDT by schiebe
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-21 11:15:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description schiebe 2003-04-18 14:25:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
When i try to install a rpm (by clicking on it) the installer starts for a short
time and then he closed itself atomatically.
And he hangs after installing. RH 8 like :-)
The same in the console like rpm -Uhv 

Version-Release number of selected component (if applicable):
rpm-4.2-0.69

How reproducible:
Sometimes

Steps to Reproduce:
1.install varios rpms
2.
3.
    

Additional info:
Comment 1 Adrian Gartland 2003-04-19 19:11:12 EDT
I have the same problem. Used to happen all the time for me on RH8 too.
[root@ade ade]# apt-get install gstreamer
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  gstreamer-tools
The following packages will be upgraded
  gstreamer gstreamer-tools
2 packages upgraded, 0 newly installed, 0 removed and 6 not upgraded.
Need to get 421kB of archives.
After unpacking 592kB disk space will be freed.

Do you want to continue? [Y/n] y
Get:1 http://gstreamer.net redhat-9-i386/redhat gstreamer-tools 0.6.1-1
[40.3kB]Get:2 http://gstreamer.net redhat-9-i386/redhat gstreamer 0.6.1-1 [380kB]
Fetched 421kB in 9s (44.0kB/s)
Executing RPM (-Uvh)...
Preparing...                ########################################### [100%]
   1:gstreamer-tools        ########################################### [ 50%]
<HANGS>

[root@ade ade]# strace -p 1852
futex(0x4058d040, FUTEX_WAIT, 0, NULL <unfinished ...>

[ade@ade ade]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) Processor
stepping        : 2
cpu MHz         : 1200.052
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr syscall mmxext 3dnowext 3dnow
bogomips        : 2392.06
 
Comment 2 Jeff Johnson 2003-04-21 10:14:48 EDT
Do you have pointers to packages? If so I can verify
that CLI install works ...
Comment 3 schiebe 2003-04-21 10:44:17 EDT
Sorry. what mean pointers to package? Iam not from us :-)
But i have an example:

[root@campgrounds schiebe]# rpm -e lmule-1.1.13c-fr2
(hangs since 5 min..)
(the lmule package is from freshrpms.net- extra build for RH9)

[root@campgrounds schiebe]# strace -p 18063
futex(0x405c415c, FUTEX_WAIT, 0, NULL <unfinished ...>
Comment 4 Jeff Johnson 2003-04-21 10:52:59 EDT
OK, so the problem affects many packages, not just gstreamer.

Have you tried
    rm -f /var/lib/rpm/__db*
Comment 5 schiebe 2003-04-21 11:13:41 EDT
Now it work! The packages is erased. 
?!

Note You need to log in before you can comment on or make changes to this bug.