Bug 89177 - unable to switch to kdm
unable to switch to kdm
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-19 05:42 EDT by Peer Hebing
Modified: 2014-03-16 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-21 11:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peer Hebing 2003-04-19 05:42:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
This seems to be wrong 
if [ -f /etc/sysconfig/desktop ]; then
        . /etc/sysconfig/desktop
        if [ "$DISPLAYMANAGER" = GNOME ]; then
                preferred=gdm
        elif [ "DISPLAYMANAGER" = KDE ]; then
                preferred=kdm
        elif [ "$DISPLAYMANAGER" = XDM ]; then
                preferred=xdm
        fi




Version-Release number of selected component (if applicable):
initscripts-7.14-1

How reproducible:
Always

Steps to Reproduce:
1.Select KDE as prefered Desktop
2. Boot to runlevel 5

    

Actual Results:  gdm is coming up instead of kdm even if the prefered Desktop in 
/etc/sysconfig/desktop is KDE

Expected Results:  It should start kdm 

Additional info:
upgraded from RH 8.0 i have DESKTOP="KDE" in /etc/sysconfig/desktop.
I think it has to be $DESKTOP instead of $DISPLAYMANAGER in this case
Comment 1 Bill Nottingham 2003-04-21 11:55:28 EDT
No, this was intentional.

Note You need to log in before you can comment on or make changes to this bug.