Bug 89198 - PHP flush() problem and phpwiki
PHP flush() problem and phpwiki
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
http://sourceforge.net/forum/forum.ph...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-20 09:36 EDT by Russell McOrmond
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 11:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell McOrmond 2003-04-20 09:36:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
PHPWiki http://sourceforge.net/projects/phpwiki/ installed on RedHat 8.0
(httpd-2.0.40-11 php-4.2.2-8.0.7) ends up displaying scrambled characters rather
than displaying a page.

On advise of someone else <http://www.perc.ca/phpBB2/viewtopic.php?t=172> I
commenting out a few specific calls to flush() which solved (masked) the problem.


  I suspect there is some uninitialized variable somewhere in eithor PHP or
Apache that phpwiki is twiddling.

There appears to be different results with different clients.  When I telnet and
do a GET request by hand I get characters displayed that I don't see if I use
wget to the same URL.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install phpwiki
2. view page with Mozilla and see garbage page
3. comment out flush() calls in display.php
4. view page with Mozilla and see expected page.    

Additional info:
Comment 1 Joe Orton 2003-05-06 11:51:31 EDT
The "2cbc" strings you see in telnet are chunked encoding - send HTTP/1.0 not
/1.1 in the request-line if you don't want to see them.

Can you narrow this down to a single page which is reproducibly broken?
Comment 2 Russell McOrmond 2003-05-06 11:58:17 EDT
Please install phpwiki on the Apache from RedHat 8.0 and you will see the problem.
Remove the flush() calls and the problem will go away.

This is where we detected the problem, but suspect that the problem shows up in
other places as well.
Comment 3 Joe Orton 2005-01-25 11:48:29 EST
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.

Note You need to log in before you can comment on or make changes to this bug.