Bug 8920 - Can't set interface MTU with ifconfig
Can't set interface MTU with ifconfig
Status: CLOSED DUPLICATE of bug 9215
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On: 9215
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-27 09:35 EST by eugene
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-07 11:10:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eugene 2000-01-27 09:35:39 EST
Trying to set the MTU value for an interface:
ifconfig eth0 mtu 1400
--causes the following error.
SIOCSIFMTU:Invalid argument

A workaround appears to be:
echo 1 > /proc/sys/net/ipv4/ip_always_defrag
echo 1 > /proc/sys/net/ipv4/ip_no_pmtu_disc

This error occurred after upgrading to 6.1.
I was able to use ifconfig to set the MTU on a different machine (identical
processors and ethernet cards) that had 6.1 installed on it originally.
Comment 1 Elliot Lee 2000-02-03 15:29:59 EST
I can't reproduce this problem on either of my boxen. It may be that your
networking configuration is different on the upgraded system, and a
feature/limitation of the kernel or hardware is preventing you from changing the
MTU.
Comment 2 Jeff Johnson 2000-10-07 11:08:53 EDT

*** This bug has been marked as a duplicate of 9129 ***
Comment 3 Jeff Johnson 2000-10-07 11:11:14 EDT

*** This bug has been marked as a duplicate of 9215 ***

Note You need to log in before you can comment on or make changes to this bug.