Bug 892087 - [RFE] resize-guest display with spice
[RFE] resize-guest display with spice
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-05 02:12 EST by Geyang Kong
Modified: 2014-02-12 06:12 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-12 06:12:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geyang Kong 2013-01-05 02:12:16 EST
Description of problem:
  Remote-viewer should make guest to restore original resolution when disconnect it.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-18.el6.x86_64
spice-server-0.12.0-10.el6.x86_64
spice-glib-0.14-6.el6.x86_64
spice-gtk-python-0.14-6.el6.x86_64
spice-gtk-tools-0.14-6.el6.x86_64
spice-gtk-0.14-6.el6.x86_64
spice-vdagent-0.12.0-3.el6.x86_64

Reproduce steps:
1. Install a RHEL6.4 host and a RHEL6.4 guest with gnome.
2. Make sure guest has spice+qxl video devices and spicevmc channel exists.
3. Upgrade spice packages in both host and guest.
4. Have at least 2 physical monitors plugged on the host.
5. remote-viewer spice://127.0.0.1:5900 --full-screen=auto-conf
6. Close remote-viewer, and launch viewer form from virt-manager

Actual results:
1. After step 6, guest will hold the "amazing" resolution, it's very hard to visit the guest through virt-manager.

Expected results:
1. Remote-viewer should make guest to restore original resolution when disconnect it

Additional info:
Comment 1 Geyang Kong 2013-01-05 04:06:44 EST
Normally, user will not hit this issue with a vnc guest, its highest resolution is 1024x768. But for spice, especially the guest has been connected by a user with multiple physical monitors, its resolution could be very high. It will be almost impossible for a user who wants to visit the guest through virt-manager and very hard to set resolution manually. So I think, at least, virt-viewer should remember original resolution when a spice guest was connected by a machine with multiple monitors, and set it back when disconnect it. This will not affect virt-viewer's user since they can easily set the resolution, but will make virt-manager's user much more happier.
Comment 2 Marc-Andre Lureau 2013-05-16 08:20:08 EDT
This sounds like the wrong solution to a problem. Instead virt-manager should use the auto-resize functionality (even by default if it's not in UI), which it used to have before 64f201eff8. Reassigning there.
Comment 3 Martin Kletzander 2013-07-16 01:01:28 EDT
virt-manager has the "Resize to VM" option which does exactly that, but not automatically.  We don't want the window to be automatically the same size as the guest's desktop because it can be way larger than the host screen, so I'd leave it at manual change on connection only.  In case your request was misunderstood, feel free to reopen this BZ.
Comment 4 Marc-Andre Lureau 2013-07-16 06:52:59 EDT
(In reply to Martin Kletzander from comment #3)
> virt-manager has the "Resize to VM" option which does exactly that, but not
> automatically.  We don't want the window to be automatically the same size
> as the guest's desktop because it can be way larger than the host screen, so
> I'd leave it at manual change on connection only.  In case your request was
> misunderstood, feel free to reopen this BZ.

spice-gtk display resize-guest will make the guest resolution match the client display size. Not the other way around.
Comment 7 Cole Robinson 2014-02-11 15:43:04 EST
Are any customers or partners actually asking for this? The reporter was from RH virt QE. If there isn't any good business case for this I say we defer to RHEL7.

The virt-manager console code is quite finicky so doing the backports to make it work nicely with resize-guest is scary IMO. It would be better to just tell interested parties to use virt-viewer/remote-viewer.
Comment 8 Cui Lei 2014-02-11 21:20:10 EST
Agree with Cole, it's a RFE which submitted by virt QE. And virt-viewer could meet the requirement.
As Cole's description, please go ahead to defer this bug. When any customer ask for this, we could pick it up then
Comment 9 Giuseppe Scrivano 2014-02-12 06:12:08 EST
given the above comments, I am closing it as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.