Bug 892198 - X crashes (works somewhat when libglx is disabled)
X crashes (works somewhat when libglx is disabled)
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
18
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-05 15:14 EST by Yaniv Kaul
Modified: 2013-12-09 12:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 12:40:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log - when it loaded without glx (25.00 KB, text/x-log)
2013-01-05 15:15 EST, Yaniv Kaul
no flags Details
yum log - perhaps it is one of the latest updates (22.15 KB, text/x-log)
2013-01-05 15:16 EST, Yaniv Kaul
no flags Details
startx with LIBGL_DEBUG=verbose (12.82 KB, text/plain)
2013-01-05 15:18 EST, Yaniv Kaul
no flags Details

  None (edit)
Description Yaniv Kaul 2013-01-05 15:14:46 EST
Description of problem:
My X failed to load. For quite some time now I had to login and perform 'startx' (although I was supposed to be on 'init 5' mode), but two days ago I had to reboot, and when I did, I could no longer run X. The only way to launch it is without libglx, but then I have a lot of items missing.
I believe an authentication/systemd/other issue, actually.

Workarounds tried: add user to 'video' group (so it won't complained on access problems to /dev/dri/card0).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Kaul 2013-01-05 15:15:32 EST
Created attachment 673028 [details]
Xorg.0.log - when it loaded without glx
Comment 2 Yaniv Kaul 2013-01-05 15:16:25 EST
Created attachment 673029 [details]
yum log - perhaps it is one of the latest updates

I've tried downgrading all possibly related RPMs, that did not help either.
Comment 3 Yaniv Kaul 2013-01-05 15:18:11 EST
Created attachment 673030 [details]
startx with LIBGL_DEBUG=verbose

Note the following:
gnome-session[1741]: WARNING: Could not get session id for session. Check that logind is properly installed and pam_systemd is getting used at login.

I suspected it, but not idea how to solve it.
Comment 4 Yaniv Kaul 2013-01-05 15:25:40 EST
My main suspicion is around systemd, which started the whole problems (where the computer won't boot directly into X, although default.target -> /lib/systemd/system/graphical.target correctly linked.

Note You need to log in before you can comment on or make changes to this bug.