Bug 892320 - Endpoint not found error showing up in httpd error.log for Horizon
Endpoint not found error showing up in httpd error.log for Horizon
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-keystoneclient (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
medium Severity low
: snapshot3
: 2.1
Assigned To: Alan Pevec
Nir Magnezi
: Triaged
Depends On: 896157
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-06 12:07 EST by Perry Myers
Modified: 2013-03-05 13:30 EST (History)
2 users (show)

See Also:
Fixed In Version: python-keystoneclient-0.2.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 13:30:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1036342 None None None Never

  None (edit)
Description Perry Myers 2013-01-06 12:07:44 EST
Description of problem:
Looking at /var/log/httpd/error.log on the Horizon server, one sees a lot of this snippet:

[Sun Jan 06 10:55:26 2013] [error] unable to retrieve service catalog with token
[Sun Jan 06 10:55:26 2013] [error] Traceback (most recent call last):
[Sun Jan 06 10:55:26 2013] [error]   File "/usr/lib/python2.6/site-packages/keystoneclient/v2_0/client.py", line 135, in _extract_service_catalog
[Sun Jan 06 10:55:26 2013] [error]     endpoint_type='adminURL')
[Sun Jan 06 10:55:26 2013] [error]   File "/usr/lib/python2.6/site-packages/keystoneclient/service_catalog.py", line 73, in url_for
[Sun Jan 06 10:55:26 2013] [error]     raise exceptions.EndpointNotFound('Endpoint not found.')
[Sun Jan 06 10:55:26 2013] [error] EndpointNotFound: Endpoint not found.

This happens pretty much on any operation you take in the Horizon interface.

A quick upstream bug search finds:
https://bugs.launchpad.net/python-keystoneclient/+bug/1036342

Which indicates that this was an issue fixed in keystone client 2.0

Our current version of keystoneclient in RHOS is python-keystoneclient-0.1.3.27-1.el6.noarch

I checked exceptions.py and the EmptyCatalog exception doesn't appear to be in our version, so it looks like this patch didn't make it into the Folsom stable branch yet.

So perhaps we need to backport this patch to get rid of the error message, which might be a red herring for users
Comment 2 Yaniv Kaul 2013-01-28 07:44:40 EST
How do we test this?
Comment 3 Yaniv Kaul 2013-02-04 07:48:44 EST
(In reply to comment #2)
> How do we test this?

Answer to self: happens on my environment as well.
Comment 6 Nir Magnezi 2013-02-24 10:21:44 EST
Verified NVR: python-keystoneclient-0.2.0-1.el6ost.noarch

1. I Ran sanity test in order to trigger the error mentioned in Comment #0 
2. I Checked the logs at /var/log/httpd and I didn't find the error mentioned above
Comment 8 errata-xmlrpc 2013-03-05 13:30:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0593.html

Note You need to log in before you can comment on or make changes to this bug.