Bug 892455 - Anaconda 'storage' dialog shrinks, then goes away, leaving no user elements on screen
Anaconda 'storage' dialog shrinks, then goes away, leaving no user elements o...
Status: CLOSED DUPLICATE of bug 882435
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-07 02:36 EST by Lucas Jacobs
Modified: 2013-01-07 08:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 08:51:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucas Jacobs 2013-01-07 02:36:17 EST
Description of problem:
The new Anaconda interface looks and feels great, but becomes unusable occasionally. When trying to install Fedora 18-RC1 (downloaded from https://dl.fedoraproject.org/pub/alt/stage/18-RC1/Fedora/x86_64/iso/) for the first time, I was clicking through the 'Storage' dialog to find the hard drive which contained my F17 installation, and managed to trigger the following bug: https://bugzilla.redhat.com/show_bug.cgi?id=882435 - After clicking through the dialog a few more times, the interface completely went away, leaving a blank, grey screen with no user-interactable elements such as buttons or hyperlinks on the screen.

Version-Release number of selected component (if applicable):
Fedora 18-RC1 (not sure what version of Anaconda it uses)

How reproducible:
I was able to reproduce the problem twice on my machine.

Steps to Reproduce:
1. Boot Fedora 18 RC1 64-bit 4GB DVD
2. Follow normally until at the main installation screen
3. Click on 'Storage'
4. Select some drives, hit 'Continue'
5. Check the box labelled 'Let me partition the drives myself'
6. Add, remove or just examine the partitions available
7. Click 'Back' on the top to return to the disk selection screen
8. Repeat steps 4 through 7 until the display elements occupy a small (about 800x600) portion on the upper-left of the screen
9. Click 'Back' on the top to return to the main installation screen
10. Click on 'Storage'
11. Repeat steps 9 through 10 (or perhaps 4 through 7) until screen goes blank

Actual results:
Screen is blank, nothing to click, hovering over certain parts of the screen may cause cursor to change into a hand icon but clicking will not produce any visible results

Expected results:
Anaconda navigates through these screens as normal

Additional info:
I'm using four drives. Two have full NTFS partitions, one is a SSD with 80GB for Windows 8 and about 30GB left unpartitioned intended for Fedora, and another has the following layout: 500MB EXT4 boot, 50GB BTRFS root, 250GB BTRFS home, 8GB swap, with an old, unused Fedora 17 installation on it.
Comment 1 Chris Lumens 2013-01-07 08:51:24 EST
Yeah, there's something strange going on that causes that shrinking interface.  Once that happens, I don't trust anything that happens after it so I'd believe that widgets are disappearing.  I'm going to mark as a dupe because I believe fixing the initial problem will fix subsequent problems.

*** This bug has been marked as a duplicate of bug 882435 ***

Note You need to log in before you can comment on or make changes to this bug.