Bug 892676 - [abrt] Zim-0.57-2.fc18: socket.py:224:meth:error: [Errno 2] No such file or directory
[abrt] Zim-0.57-2.fc18: socket.py:224:meth:error: [Errno 2] No such file or d...
Status: CLOSED DUPLICATE of bug 885262
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:24297ed8d5fb28326950878945e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-07 10:12 EST by Brian J. Murrell
Modified: 2013-01-07 22:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:32:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.17 KB, text/plain)
2013-01-07 10:12 EST, Brian J. Murrell
no flags Details
File: core_backtrace (783 bytes, text/plain)
2013-01-07 10:12 EST, Brian J. Murrell
no flags Details
File: environ (1.60 KB, text/plain)
2013-01-07 10:12 EST, Brian J. Murrell
no flags Details

  None (edit)
Description Brian J. Murrell 2013-01-07 10:12:10 EST
Version-Release number of selected component:
Zim-0.57-2.fc18

Additional info:
cmdline:        /usr/bin/python /usr/bin/zim
dso_list:       python-libs-2.7.3-13.fc18.x86_64
executable:     /usr/bin/zim
kernel:         3.6.9-4.fc18.x86_64
uid:            1001

Truncated backtrace:
socket.py:224:meth:error: [Errno 2] No such file or directory

Traceback (most recent call last):
  File "/usr/bin/zim", line 73, in <module>
    zim.main(argv)
  File "/usr/lib/python2.7/site-packages/zim/__init__.py", line 445, in main
    gui = server.get_notebook(notebook)
  File "/usr/lib/python2.7/site-packages/zim/ipc.py", line 753, in get_notebook
    return self.get_proxy(RemoteObject(self._notebookklass, uri), open)
  File "/usr/lib/python2.7/site-packages/zim/ipc.py", line 734, in get_proxy
    if not self.has_object(remoteobject):
  File "/usr/lib/python2.7/site-packages/zim/ipc.py", line 699, in call
    conn = Client(SERVER_ADDRESS, SERVER_ADDRESS_FAMILY)
  File "/usr/lib64/python2.7/multiprocessing/connection.py", line 169, in Client
    c = SocketClient(address)
  File "/usr/lib64/python2.7/multiprocessing/connection.py", line 293, in SocketClient
    s.connect(address)
  File "/usr/lib64/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 2] No such file or directory

Local variables in innermost frame:
self: <socket._socketobject object at 0x7f29b64ef590>
args: ('/tmp/zim-brian/zim-server-socket',)
name: 'connect'

Potential duplicate: bug 878665
Comment 1 Brian J. Murrell 2013-01-07 10:12:12 EST
Created attachment 674122 [details]
File: backtrace
Comment 2 Brian J. Murrell 2013-01-07 10:12:14 EST
Created attachment 674123 [details]
File: core_backtrace
Comment 3 Brian J. Murrell 2013-01-07 10:12:16 EST
Created attachment 674124 [details]
File: environ
Comment 4 Robin Lee 2013-01-07 22:32:13 EST

*** This bug has been marked as a duplicate of bug 885262 ***

Note You need to log in before you can comment on or make changes to this bug.