Bug 892995 - users/powerusers cannot consume quota on an upgraded pre-quota DB
users/powerusers cannot consume quota on an upgraded pre-quota DB
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Gilad Chaplik
Ondra Machacek
sla
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 07:24 EST by ofri
Modified: 2016-02-10 15:20 EST (History)
9 users (show)

See Also:
Fixed In Version: sf4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 17:06:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10746 None None None Never

  None (edit)
Description ofri 2013-01-08 07:24:42 EST
Description of problem:
When trying to add Quota consumers, it seems like the operation succeeded but nothing happens (the consumer is not added to the list).


Version-Release number of selected component (if applicable):
3.1


How reproducible:
100%

Steps to Reproduce:
1. try to add consumer to quota
  
Actual results:
consumer not added to list


Expected results:
consumer added to list

Additional info:
Comment 1 ofri 2013-01-08 07:42:12 EST
the quota consumer is added to DB but not shown in the list. This happens because of missing entry in the DB role_groups table.

The missing entry is created only when DB is first created but not if the DB was upgraded. The SQL query adding the entry was accidentally added to insert_predefined_roles.sql instead of being added to a new upgrade script.

Since UI is filtering the quota consumers view by this entry - the list remains empty. Nevertheless, consumers added to the quota can still consume it.
Comment 3 Doron Fediuck 2013-01-09 03:27:03 EST
Since the users are actually getting the right permissions,
this is mostly an ugly UI/UX issue. Consumers should be able to
work as needed.
Comment 4 ofri 2013-01-09 08:16:30 EST
posted upstream: http://gerrit.ovirt.org/#/c/10746/
Comment 10 Ondra Machacek 2013-11-19 11:23:03 EST
ok in latest sf, upgrade from ic159 to si29.4 to sf21.1. User can consume quota.

Note You need to log in before you can comment on or make changes to this bug.