Bug 8931 - Rawhide Powertools issue with (and fix for) GNATS 3.113 ...
Summary: Rawhide Powertools issue with (and fix for) GNATS 3.113 ...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: gnats   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-27 22:02 UTC by Bryan J. Smith
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-29 12:26:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan J. Smith 2000-01-27 22:02:23 UTC
Rawhide Powertools issue with (and fix for) GNATS 3.113 ...
(gnats-3.113-2.i386.rpm)

In your compiled version, it expects a number of config files (e.g.,
./gnats-adm/gnatsd.conf) and the queue directory (./gnats-queue) to be in
/var/lib/gnats.

But the GNATS DB support RPM (gnats-db-3.113-2.i386.rpm), puts them in
/usr/share/gnats/gnats-db instead.  You may wish to change the above to
match GNATS DB.

A quick fix to this is, of course, to use a symbolic link:
   ln -s /usr/share/gnats/gnats-db /var/lib/gnats

Just FYI.  Cannot wait for RedHat and Powertools 6.2 (and don't call it 7.0
just because Mandrake jumped to 7.0, got I hate that! ;-).

Comment 1 Tim Powers 2000-01-29 12:26:59 UTC
OK. Check out the 3.113-3 release whenever rawhide gets updated. It's fixed.
Feel free to reopen this bug if you continue to have problems.


Note You need to log in before you can comment on or make changes to this bug.