Bug 893664 - [abrt] sssd-1.9.3-1.fc18: be_host_handler: Process /usr/libexec/sssd/sssd_be was killed by signal 11 (SIGSEGV)
[abrt] sssd-1.9.3-1.fc18: be_host_handler: Process /usr/libexec/sssd/sssd_be ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
abrt_hash:35096b09bcab7437289481f348a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 11:10 EST by Orion Poplawski
Modified: 2013-02-08 03:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 17:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (38.99 KB, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: cgroup (154 bytes, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: core_backtrace (1.13 KB, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: dso_list (5.44 KB, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: environ (179 bytes, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: maps (26.28 KB, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: open_fds (1.08 KB, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: proc_pid_status (889 bytes, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
File: var_log_messages (313 bytes, text/plain)
2013-01-09 11:10 EST, Orion Poplawski
no flags Details
sssd.conf (579 bytes, text/plain)
2013-01-10 11:07 EST, Orion Poplawski
no flags Details
sssd_nwra.com.log.gz (8.09 KB, application/x-gzip)
2013-01-14 17:21 EST, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2013-01-09 11:10:38 EST
Description of problem:
Testing out using an ipa server with sssd.

Version-Release number of selected component:
sssd-1.9.3-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/libexec/sssd/sssd_be --domain default --debug-to-files
crash_function: be_host_handler
executable:     /usr/libexec/sssd/sssd_be
kernel:         3.6.11-3.fc18.x86_64
remote_result:  NOTFOUND
uid:            0

Truncated backtrace:
Thread no. 1 (9 frames)
 #0 be_host_handler at src/providers/data_provider_be.c:1721
 #1 sbus_message_handler at src/sbus/sssd_dbus_connection.c:430
 #2 _dbus_object_tree_dispatch_and_unlock at dbus-object-tree.c:862
 #4 sbus_dispatch at src/sbus/sssd_dbus_connection.c:104
 #5 tevent_common_loop_timer_delay at ../tevent_timed.c:254
 #6 std_event_loop_once at ../tevent_standard.c:560
 #7 _tevent_loop_once at ../tevent.c:507
 #8 tevent_common_loop_wait at ../tevent.c:608
 #9 server_loop at src/util/server.c:601
Comment 1 Orion Poplawski 2013-01-09 11:10:41 EST
Created attachment 675698 [details]
File: backtrace
Comment 2 Orion Poplawski 2013-01-09 11:10:42 EST
Created attachment 675699 [details]
File: cgroup
Comment 3 Orion Poplawski 2013-01-09 11:10:45 EST
Created attachment 675700 [details]
File: core_backtrace
Comment 4 Orion Poplawski 2013-01-09 11:10:47 EST
Created attachment 675701 [details]
File: dso_list
Comment 5 Orion Poplawski 2013-01-09 11:10:49 EST
Created attachment 675702 [details]
File: environ
Comment 6 Orion Poplawski 2013-01-09 11:10:51 EST
Created attachment 675703 [details]
File: limits
Comment 7 Orion Poplawski 2013-01-09 11:10:52 EST
Created attachment 675704 [details]
File: maps
Comment 8 Orion Poplawski 2013-01-09 11:10:54 EST
Created attachment 675705 [details]
File: open_fds
Comment 9 Orion Poplawski 2013-01-09 11:10:56 EST
Created attachment 675706 [details]
File: proc_pid_status
Comment 10 Orion Poplawski 2013-01-09 11:10:58 EST
Created attachment 675707 [details]
File: var_log_messages
Comment 11 Jakub Hrozek 2013-01-09 16:37:07 EST
Hello Orion, thank you for the bug report. This is not a know issue. We'll investigate it..in the meantime, can you tell us more about the crash? Did it occur during login? Any other details that might help us?
Comment 12 Jakub Hrozek 2013-01-09 16:40:09 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1751
Comment 13 Orion Poplawski 2013-01-09 16:43:00 EST
Well, it seems to be segfaulting regularly:

Jan  9 10:54:29 barry kernel: [438308.105684] sssd_be[24418]: segfault at 8 ip 00007f212f583035 sp 00007fffb95415a0 error 4 in sssd_be[7f212f570000+89000]
Jan  9 11:43:02 barry kernel: [441221.132206] sssd_be[25578]: segfault at 8 ip 00007f94bc927035 sp 00007fff44654bf0 error 4 in sssd_be[7f94bc914000+89000]
Jan  9 12:00:06 barry kernel: [442244.729489] sssd_be[26558]: segfault at 8 ip 00007f5b0827c035 sp 00007fff40461bf0 error 4 in sssd_be[7f5b08269000+89000]
Jan  9 12:03:21 barry kernel: [442440.118225] sssd_be[26891]: segfault at 8 ip 00007fc0c7ef0035 sp 00007fff0e17c080 error 4 in sssd_be[7fc0c7edd000+89000]
Jan  9 12:03:47 barry kernel: [442466.121605] sssd_be[26993]: segfault at 8 ip 00007f4cdee75035 sp 00007fffa9ba6bb0 error 4 in sssd_be[7f4cdee62000+89000]
Jan  9 12:23:34 barry kernel: [443653.151605] sssd_be[27059]: segfault at 8 ip 00007f2b0fad3035 sp 00007fffe9381940 error 4 in sssd_be[7f2b0fac0000+89000]
Jan  9 13:33:31 barry kernel: [447849.813267] sssd_be[27345]: segfault at 8 ip 00007f79f5adb035 sp 00007fffa7031460 error 4 in sssd_be[7f79f5ac8000+89000]

I'm not able to tie it do any other events.  I can turn on debugging if that would help.
Comment 14 Jakub Hrozek 2013-01-10 11:00:50 EST
The sanitized sssd.conf would be welcome in reproducing the error.
Comment 15 Orion Poplawski 2013-01-10 11:07:50 EST
Created attachment 676403 [details]
sssd.conf

Here you go.
Comment 16 Jakub Hrozek 2013-01-14 16:24:51 EST
Hi,
I tried to reproduce your problem again without success..could you provide the debug logs after all? I'm mostly interested in seeing the domain logs, including startup. To generate them, put debug_level=10 into the domain section of the sssd, restart the sssd and then attach /var/log/sssd/sssd_domain.log

Judging by the debug information you pasted on IRC it seems that the hostid module is not being loaded for one reason or another.

In particular, what are the messages that mention be_process_init and load_backend_module?

In my case they look like this:
(Mon Jan 14 16:19:39 2013) [sssd[be[EXAMPLE.COM]]] [be_process_init] (0x4000): HOST backend target successfully loaded from provider [ipa].
(Mon Jan 14 16:19:39 2013) [sssd[be[EXAMPLE.COM]]] [load_backend_module] (0x0200): no module name found in confdb, using [ipa].
(Mon Jan 14 16:19:39 2013) [sssd[EXAMPLE.COM]]] [load_backend_module] (0x1000): Backend [ipa] already loaded.

I'm sorry for the constant back-and-forth. There is definitely a bug, I'm just not seeing it at the moment.
Comment 17 Orion Poplawski 2013-01-14 17:21:17 EST
Created attachment 678451 [details]
sssd_nwra.com.log.gz

Here's the startup.

(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x1000): Loading backend [ipa] with path [/usr/lib64/sssd/libsss_ipa.so].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x2000): ID backend target successfully loaded from provider [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x1000): Backend [ipa] already loaded.
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x2000): AUTH backend target successfully loaded from provider [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x1000): Backend [ipa] already loaded.
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x2000): ACCESS backend target successfully loaded from provider [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x1000): Backend [ipa] already loaded.
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x2000): CHPASS backend target successfully loaded from provider [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init_sudo] (0x0400): SUDO is not listed in services, disabling SUDO module.
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x0080): No SUDO module provided for [nwra.com] !!
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x0200): no module name found in confdb, using [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x1000): Backend [ipa] already loaded.
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x2000): autofs backend target successfully loaded from provider [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x0200): no module name found in confdb, using [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x1000): Backend [ipa] already loaded.
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x4000): selinux backend target successfully loaded from provider [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x0200): no module name found in confdb, using [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x1000): Backend [ipa] already loaded.
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x4000): HOST backend target successfully loaded from provider [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x0200): no module name found in confdb, using [ipa].
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [load_backend_module] (0x1000): Backend [ipa] already loaded.
(Mon Jan 14 15:16:05 2013) [sssd[be[nwra.com]]] [be_process_init] (0x4000): Get-Subdomains backend target successfully loaded from provider [ipa].
[
Comment 18 Pavel Březina 2013-01-31 04:39:13 EST
Hi,
you said that you don't see the crash anymore after you've made some configuration changes. Can you please attach your latest sssd.conf please? There might be some trail.
Comment 19 Orion Poplawski 2013-01-31 10:42:38 EST
< old > new
1a2
> debug_level = 10
9d9
< ipa_hostname = barry.subdomain.example.com

I'll try reverting and see it that changes anything.
Comment 20 Jakub Hrozek 2013-01-31 11:57:33 EST
In my setup, setting ipa_hostname or not didn't make a difference (with git head, though).
Comment 21 Jakub Hrozek 2013-02-07 13:26:17 EST
Any luck in reproducing the issue?
Comment 22 Orion Poplawski 2013-02-07 17:07:16 EST
Nope.
Comment 23 Jakub Hrozek 2013-02-08 03:30:40 EST
Thank you, please reopen if the issue hits again.

Note You need to log in before you can comment on or make changes to this bug.