Bug 893672 - libvirt-qmf is not properly obsoleted in RHEL 6.4 beta
libvirt-qmf is not properly obsoleted in RHEL 6.4 beta
Status: CLOSED DUPLICATE of bug 894155
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt-qmf (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: 6.4
Assigned To: Jeff Peeler
Dave Johnson
:
: 828957 (view as bug list)
Depends On:
Blocks: 830087
  Show dependency treegraph
 
Reported: 2013-01-09 11:43 EST by Perry Myers
Modified: 2013-01-15 12:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-15 12:59:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-01-09 11:43:07 EST
Description of problem:

If you have libvirt-qmf installed in RHEL 6.3 and then update to RHEL 6.4, the new matahari empty package attempts to Obsolete all of the matahari dependencies and _should_ also Obsolete libvirt-qmf

Instead what happens is yum errors out because libvirt-qmf dependencies are removed by the Obsoletes process.  So as of right now the Obsolete logic used by the matahari package is not successfully working

So to replicate:
1. start with RHEL 6.3.z only
2. install libvirt-qmf which pulls in some matahari deps (but not top
   level matahari package)
3. Enable beta channel, disable non-beta
4. yum update

Presence of the empty matahari package in the beta channel will obsolete
the matahari deps brought in via libvirt-qmf but because libvirt-qmf has
deps on specific matahari libraries, the yum transaction will fail

The above error also happens if you do:
1. start with RHEL 6.3.z only
2. install libvirt-qmf which pulls in some matahari deps (but not top
   level matahari package)
2a. Manually install matahari top level package
3. Enable beta channel, disable non-beta
4. yum update

One solution is to create an empty libvirt-qmf RPM in parallel with the empty matahari RPM and then remove the Obsoletes libvirt-qmf line from the matahari spec file.  So this might need to be two different bugs, one for libvirt-qmf and one for matahari
Comment 1 Perry Myers 2013-01-14 08:22:33 EST
*** Bug 828957 has been marked as a duplicate of this bug. ***
Comment 4 Zane Bitter 2013-01-14 10:02:32 EST
Would adding "Provides: libvirt-qmf" to the (empty) matahari package also fix this? That might be a quicker way.
Comment 6 Jeff Peeler 2013-01-14 11:03:41 EST
If I'm understanding correctly, that would work on a new install, but wouldn't solve the upgrade problem (which I just tested).
Comment 8 Perry Myers 2013-01-15 12:59:41 EST
It turns out that we were able to fix the string used in the Obsoletes directive in the matahari spec file to properly obsolete libvirt-qmf.  So a new libvirt-qmf build isn't needed and this bug is effectively a duplicate of bug # 894155

Thanks to james from the RPM team for helping us to sort this out :)

*** This bug has been marked as a duplicate of bug 894155 ***

Note You need to log in before you can comment on or make changes to this bug.