Bug 893770 - libreoffice-ogltrans own a directory with libreoffice-impress
libreoffice-ogltrans own a directory with libreoffice-impress
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 16:35 EST by Michael Scherer
Modified: 2013-01-21 01:58 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 01:58:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against rawhide to remove duplicate directory ownership (6.42 KB, patch)
2013-01-11 06:41 EST, Michael Scherer
no flags Details | Diff

  None (edit)
Description Michael Scherer 2013-01-09 16:35:37 EST
$ rpm -qf /usr/lib64/libreoffice/share/config/soffice.cfg/simpress/
libreoffice-impress-3.6.3.2-8.fc18.x86_64
libreoffice-ogltrans-3.6.3.2-8.fc18.x86_64

yet :
$ rpm -q --requires libreoffice-ogltrans | grep libreoffice-impress 
libreoffice-impress = 1:3.6.3.2-8.fc18

so libreoffice-ogltrans should not own the directory
Comment 1 David Tardon 2013-01-09 23:58:02 EST
I know about this. And it is not the only such case... But cleaning it has very low priority in my eyes (unless you can convince me it is a real problem).
Comment 2 Michael Scherer 2013-01-10 14:38:25 EST
That's not urgent, but I was coding a tool to detect such problem and the sooner all existing errors will be corrected, the sooner I can integrate it in fedora-review or elsewhere.

If I provides a patch, would that help ?
Comment 3 David Tardon 2013-01-10 23:59:46 EST
(In reply to comment #2)
> That's not urgent, but I was coding a tool to detect such problem and the
> sooner all existing errors will be corrected, the sooner I can integrate it
> in fedora-review or elsewhere.

Why would errors in existing packages need to be fixed before? Noone will see them until he runs fedora-review on such a package; or did I miss something?

> 
> If I provides a patch, would that help ?

Sure.
Comment 4 Michael Scherer 2013-01-11 05:57:43 EST
My plan for the tool was to take the newly built package, install it in mock ( with deps ), and run the script to see if there is duplicate ownership of directory, or missing directory.

If a package requires libreoffice, then all issues caused by the existing package libreoffice would be seen in the chroot mixed with those of the newly built package, and this add some noise to the report for issue not related to the review.
Comment 5 Michael Scherer 2013-01-11 06:41:10 EST
Created attachment 676817 [details]
patch against rawhide to remove duplicate directory ownership
Comment 6 Michael Scherer 2013-01-11 06:41:58 EST
I foun dout that most of the %dir in subpackage are also in -core, for good reason, so I removed them ( unless there is a plan to remove -core package )
Comment 7 David Tardon 2013-01-21 01:58:49 EST
thank you for the patch

Note You need to log in before you can comment on or make changes to this bug.