Bug 893774 - file shipped twice in eclipse-platform and eclipse-equinox-osgi
file shipped twice in eclipse-platform and eclipse-equinox-osgi
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 16:42 EST by Michael Scherer
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-17 07:14:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2013-01-09 16:42:45 EST
$ rpm -qf /usr/lib64/eclipse/plugins/org.eclipse.osgi.services_3.3.100.v20121126
eclipse-equinox-osgi-4.2.1-21.fc18.x86_64
eclipse-platform-4.2.1-21.fc18.x86_64

since eclipse-platform requires eclipse-equinox-osgi, it doesn't need to ship the jar file
Comment 1 Alexander Kurtakov 2013-01-09 16:49:30 EST
Chris, please take care of this one.
Comment 2 Krzysztof Daniel 2013-01-17 07:14:36 EST
org.eclipse.osgi.util_* is duplicated, too. 

I fixed it in eclipse-4.2.2-0.4.git20121217.fc18, however, the change is too small to deserve a bodhi update.
As a workaround please install/uninstall/reinstall eclipse-equinox-osgi and eclipse-platform together.

Note You need to log in before you can comment on or make changes to this bug.