Bug 893919 - Incorrect prompt when enable/disable xbzrle with "migrate_set_capability" during migration process
Incorrect prompt when enable/disable xbzrle with "migrate_set_capability" dur...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Hai Huang
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 04:02 EST by Qunfang Zhang
Modified: 2014-06-17 23:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: QEMU 1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:08:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2013-01-10 04:02:15 EST
Description of problem:
Change xbzrle value (on/off) during migration process. There will be prompt and can not change the value. This is correct but the prompt has a little problem. 

(qemu)migrate_set_capability xbzrle off
migrate_set_parameter: There's a migration process in progress

Should be : migrate_set_capability: There's a migration process in progress

I guess it's because the command was "migrate_set_parameter" in the old version of xbzrle.

Version-Release number of selected component (if applicable):
kernel-3.6.0-0.29.el7.x86_64
qemu-kvm-1.3.0-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot a guest on source host and also on destination host with listening mode "-incoming tcp:0:5800"

2. Migrate guest.
(qemu) migrate -d tcp:$dst_host_ip:5800

3. Change the xbzrle value during migration process.
(qemu)migrate_set_capability xbzrle off/on
  
Actual results:
(qemu)migrate_set_capability xbzrle off
migrate_set_parameter: There's a migration process in progress

Expected results:
(qemu)migrate_set_capability xbzrle off
migrate_set_capability: There's a migration process in progress

Additional info:
Comment 2 Orit Wasserman 2013-02-12 05:02:04 EST
Fix in QEMU 1.4
Comment 3 juzhang 2014-01-20 01:38:55 EST
(In reply to Orit Wasserman from comment #2)
> Fix in QEMU 1.4

Hi Orit,

Since this bz has been fixed in qemu1.4, would you please add this bz into corresponding errata?

Best Regards,
Junyi
Comment 5 Miroslav Rezanina 2014-02-13 02:01:28 EST
Changing to MODIFIED to fullfill errata process
Comment 7 Qunfang Zhang 2014-02-19 04:12:27 EST
Verified pass with the same steps in comment 0 with qemu-kvm-1.5.3-48.el7.x86_64.

Enable xbzrle and then do migration, try to turn off xbzrle before migration finished. It will prompt: 

(qemu) migrate_set_capability xbzrle off
migrate_set_capability: There's a migration process in progress

So this issue is fixed.
Comment 9 Ludek Smid 2014-06-13 09:08:24 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.