Bug 893938 - EC2 error codes are invalid
EC2 error codes are invalid
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
high Severity medium
: rc
: 4.0
Assigned To: Jakub Ruzicka
Gabriel Szasz
https://blueprints.launchpad.net/nova...
: TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 05:22 EST by Attila Fazekas
Modified: 2016-08-17 09:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 18:56:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 41754 None None None Never

  None (edit)
Description Attila Fazekas 2013-01-10 05:22:32 EST
EC2 has lot of documented error code here: http://docs.aws.amazon.com/AWSEC2/latest/APIReference/api-error-codes.html

I expect the Nova gives me error codes only from this set.

The nova now uses at least 4 different strategy, to report ec2 error codes, but it reports incorrect ones in all cases.

See also:
https://blueprints.launchpad.net/nova/+spec/ec2-error-codes

The *.NotFound error codes are the most important for me.

*.Duplicate are the second most important.
Comment 2 Attila Fazekas 2013-01-10 06:51:45 EST
It makes almost impossible to implement teardown functions in integration test codes, without depending on incorrect/undocumented behaviour. It also limits the possible test cases.
Comment 6 Jakub Ruzicka 2013-05-31 14:05:50 EDT
This is for Havana, moving to 4.0.
Comment 7 Jakub Ruzicka 2013-09-03 15:59:29 EDT
Some patches got merged already and the rest has been approved and are just waiting to be merged due to random gate failures.
Comment 12 Scott Lewis 2013-11-18 15:35:33 EST
Adding to beta milestone for MODIFIED/ON-QA bugs
Comment 13 Stephen Gordon 2013-11-19 10:41:28 EST
Moving milestone to rc, this should not block beta IMO.
Comment 19 errata-xmlrpc 2013-12-19 18:56:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.