Bug 89415 - Wrong version in perl-CGI, extra files included
Wrong version in perl-CGI, extra files included
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-22 16:06 EDT by Ville Skyttä
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 21:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2003-04-22 16:06:32 EDT
The perl-CGI built from perl-5.8.0-88 is apparently patched to be 2.89, but the
installed package is perl-CGI-2.81-88 (should be perl-CGI-2.89-88).

Additionally, the patching has left backup files behind that are in the perl
package:

$ rpm -ql perl | grep newcgi
/usr/lib/perl5/5.8.0/CGI.pm.newcgi
/usr/lib/perl5/5.8.0/CGI/Carp.pm.newcgi
/usr/lib/perl5/5.8.0/CGI/Cookie.pm.newcgi
/usr/lib/perl5/5.8.0/CGI/Fast.pm.newcgi
/usr/lib/perl5/5.8.0/CGI/Pretty.pm.newcgi
Comment 1 Chip Turner 2004-02-13 21:06:03 EST
this should be fixed in recent perls in rawhide; also the perl-CGI
package was re-integrated back into the perl mothership so it isn't a
separate package in the rawhide perls

Note You need to log in before you can comment on or make changes to this bug.