Bug 89441 - nameif segfaults on ia64
nameif segfaults on ia64
Status: CLOSED DUPLICATE of bug 85748
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: net-tools (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-22 17:55 EDT by dann frazier
Modified: 2015-03-04 20:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dann frazier 2003-04-22 17:55:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; Debian/1.3.3.20030414-1)
Gecko/20030327 Galeon/1.3.3

Description of problem:
# /sbin/ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:700 (700.0 b)  TX bytes:700 (700.0 b)
### no interfaces currently up
# /sbin/ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:30:6E:39:76:1F  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:56 

eth1      Link encap:Ethernet  HWaddr 00:30:6E:39:E6:87  
          inet addr:10.42.37.10  Bcast:10.255.255.255  Mask:255.0.0.0
          BROADCAST NOTRAILERS  MTU:1500  Metric:1
          RX packets:6752 errors:0 dropped:0 overruns:0 frame:0
          TX packets:641 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:9136920 (8.7 Mb)  TX bytes:57093 (55.7 Kb)
          Interrupt:53 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:700 (700.0 b)  TX bytes:700 (700.0 b)

### i have eth0 & eth1, there's my macs
# cat /etc/mactab
gig  00:30:6E:39:76:1F
fast 00:30:6E:39:E6:87
### my mactab file
# /sbin/nameif 
Segmentation fault
### ouch
# /sbin/ifconfig -a
fast      Link encap:Ethernet  HWaddr 00:30:6E:39:E6:87  
          inet addr:10.42.37.10  Bcast:10.255.255.255  Mask:255.0.0.0
          BROADCAST NOTRAILERS  MTU:1500  Metric:1
          RX packets:6752 errors:0 dropped:0 overruns:0 frame:0
          TX packets:641 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:9136920 (8.7 Mb)  TX bytes:57093 (55.7 Kb)
          Interrupt:53 

gig       Link encap:Ethernet  HWaddr 00:30:6E:39:76:1F  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:56 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:700 (700.0 b)  TX bytes:700 (700.0 b)
### appears to have worked though

Version-Release number of selected component (if applicable):
1.60-3

How reproducible:
Always

Steps to Reproduce:
1.
create a /etc/mactab file similar to the following (w/ macs on the system, of
course)
gig  00:30:63:39:76:1F
fast 00:30:69:39:E6:87
2.run /sbin/nameif
3.
    

Actual Results:  segfault

Expected Results:  no segfault

Additional info:
Comment 1 Phil Knirsch 2003-04-22 19:00:33 EDT
An updated version of the net-tools package is currently scheduled for the next
quarterly update of RHEL AS 2.1. This will inlcude a fix for this bug as well.

Thanks,

Read ya, Phil

*** This bug has been marked as a duplicate of 85748 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.