Bug 89455 - Printer S600 not working anymore in 9.0
Summary: Printer S600 not working anymore in 9.0
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: foomatic   
(Show other bugs)
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-23 01:25 UTC by Steve
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 09:56:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "printconf-tui --Xexport" (1.70 KB, text/plain)
2003-04-25 20:30 UTC, Steve
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:185 normal SHIPPED_LIVE Updated printer database available 2003-06-09 04:00:00 UTC

Description Steve 2003-04-23 01:25:07 UTC
Description of problem: Printer Canon s600 unusable under 9.0, fune under 8.0


Version-Release number of selected component (if applicable): 2.0.2


How reproducible: Always


Steps to Reproduce:
1. configure the Canon S600
2. Try to edit the config = crash
    
Actual results:
Print in economy mode (300 dpi)
When I want to set it to 600dpi, I press the Edit button and I get a crash of
redhat-config-printer:
---
# redhat-config-printer
Cannot read file /usr/share/foomatic/db/source/driver/bj8pa06n.upp.xml!Couldn't
load driver information.Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 510, in edit_button_clicked
    if self.editQueue.editQueueDialog (iter):
  File "/usr/share/printconf/util/editQueue.py", line 414, in editQueueDialog
    self.write_driver_options ()
  File "/usr/share/printconf/util/editQueue.py", line 906, in write_driver_options
    for option_tuple in option_list:
TypeError: iteration over non-sequence
---

Expected results:
Able to configure the resolution
Able to print in 600dpi

Additional info:
I could go farther using redhat-config-printer-tui
The printer was working fine in 8.0 when using a 600dpi resolution

Comment 1 Tim Waugh 2003-04-24 14:33:56 UTC
Please attach the output of 'printconf-tui --Xexport' using the 'Create a New
Attachment' link.  Thanks.

Comment 2 Steve 2003-04-25 20:30:03 UTC
Created attachment 91307 [details]
output of "printconf-tui --Xexport"

Here's the output

Comment 3 Steve 2003-05-20 19:29:17 UTC
does someone work on this? or what?  almost a month and no news?  that's really
long! I need my printer! it shouln't be that long to fix something that got broken!



Comment 4 Tim Waugh 2003-05-21 09:11:09 UTC
Sorry for the delay.

Could you please try editing the file
/usr/share/foomatic/db/source/printer/Canon-S600.xml, and change this line:

  <driver>bj8pa06n.upp</driver>

to:

  <driver>gimp-print</driver>

Does that fix the problem for you?

Comment 5 Steve 2003-05-23 20:18:39 UTC
Thanks for this "patch"

Well, this halfa fixed the problem...

now I can print, but only at 300dpi (econo mode)...
i.e. the resolution box has no effect...

normal effect of the resolutions:
300x300 (default) = econo
600x600 = normal
1200x1200 = twice the size

right now, it only print in econo, so I guess the resolution box dosen't work...

Comment 6 Steve 2003-05-23 20:21:07 UTC
I forgot to say, it fixed the gui crashing at least...
just need to fix the resolution now...

Comment 7 Tim Waugh 2003-05-23 21:31:34 UTC
See bug #88171.

Comment 8 Steve 2003-05-24 01:22:18 UTC
yes, this backslash fixed it!

Thanks :)

now bug can be closed since it work :)


Comment 9 Tim Waugh 2003-06-09 09:56:56 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-185.html



Note You need to log in before you can comment on or make changes to this bug.