Bug 89465 - mc is broken over remote logins
Summary: mc is broken over remote logins
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-23 04:31 UTC by Marc MERLIN
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-23 06:39:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing the mc brokenness (16.50 KB, image/png)
2003-04-23 04:33 UTC, Marc MERLIN
no flags Details

Description Marc MERLIN 2003-04-23 04:31:34 UTC
I log in from inside an xterm/eterm on RH 7.3 as root on a RH 9 server, and
mc, just like some other tools like netconfig looks completely broken.
It's unusable, see screenshot

Comment 1 Marc MERLIN 2003-04-23 04:33:27 UTC
Created attachment 91241 [details]
screenshot showing the mc brokenness

Notice that the font is incorrect too and displays things like a's instead
of bars.

Comment 2 Havoc Pennington 2003-04-23 06:39:49 UTC
You have to match the encoding of mc to the encoding of 
your terminal. The encoding of mc comes from the locale; for 
example, LANG=en_US.UTF-8 gives UTF-8 encoding, 
LANG=en_US.ISO-8859-1 gives Latin-1. 7.3 terminal will be expecting
Latin-1 by default. RHL 9 gnome-terminal has a menu Terminal->Character Coding
which can be used to change encoding to match remote systems.

This can't be done automatically because the ssh and telnet protocols do
not include encoding negotiation. A screwup in those protocols, so 
the only solution is to manually set your encodings properly.


Note You need to log in before you can comment on or make changes to this bug.