Bug 89478 - update japanese xdvi patch
Summary: update japanese xdvi patch
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tetex (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-23 12:28 UTC by Takanori MATSUURA
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version: 2.0.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-08 08:28:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mendexk build fix (821 bytes, patch)
2003-04-30 13:08 UTC, Takanori MATSUURA
no flags Details | Diff
badscript patch for japanese environment (741 bytes, patch)
2003-04-30 13:10 UTC, Takanori MATSUURA
no flags Details | Diff
replacement of dvipsk-jdvips.patch (3.44 KB, patch)
2003-04-30 13:11 UTC, Takanori MATSUURA
no flags Details | Diff
replacement of pxdvi.patch (7.91 KB, patch)
2003-04-30 13:13 UTC, Takanori MATSUURA
no flags Details | Diff
use autoconf213 for reautoconf (3.06 KB, patch)
2003-04-30 13:13 UTC, Takanori MATSUURA
no flags Details | Diff
modified patch of http://www.nn.iij4u.or.jp/~tutimura/tex/xdvik-22.40v-j1.17.patch.gz (144.97 KB, patch)
2003-04-30 13:14 UTC, Takanori MATSUURA
no flags Details | Diff
diff between original and my tetex.spec (6.52 KB, patch)
2003-04-30 13:15 UTC, Takanori MATSUURA
no flags Details | Diff
a patch for using Xaw3d in *xdvi (3.38 KB, patch)
2003-04-30 13:18 UTC, Takanori MATSUURA
no flags Details | Diff
diff between original tetex-2.0.2-4 and my tetex.spec (2.54 KB, patch)
2003-05-16 14:21 UTC, Takanori MATSUURA
no flags Details | Diff

Description Takanori MATSUURA 2003-04-23 12:28:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030422

Description of problem:
Japanizeation patch for xdvi in tetex-2.0.2-3 is old.
Newer one is available from 
http://www.nn.iij4u.or.jp/~tutimura/tex/xdvi.html
But the patch distributed on the site is built for applying to original xdvi
source, not xdvi in tetex-2.0.2.

So I modified the patch and build SRPM.

Fixed SRPM is available from
http://my.reset.jp/~t-matsuu/install-memo/rhl/

The following is also modified in this SRPM.
1. blushed up Japanese TeX environment
2. added mendexk, makeindex for Japanese
3. use Xaw3d in *xdvi

Version-Release number of selected component (if applicable):
tetex-2.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. run pxdvi --version
2. see the output

Comment 1 Tim Waugh 2003-04-29 11:22:16 UTC
Please provide the patches separately, rather than as one big SRPM lump.  Thanks.

Comment 2 Takanori MATSUURA 2003-04-30 13:07:16 UTC
I'll apply the patches I created and tetex.spec diff.

My "nosrc" SRPM distributed above has the size of 2.1M.

Comment 3 Takanori MATSUURA 2003-04-30 13:08:51 UTC
Created attachment 91411 [details]
mendexk build fix

Comment 4 Takanori MATSUURA 2003-04-30 13:10:42 UTC
Created attachment 91412 [details]
badscript patch for japanese environment

Comment 5 Takanori MATSUURA 2003-04-30 13:11:58 UTC
Created attachment 91413 [details]
replacement of dvipsk-jdvips.patch

Comment 6 Takanori MATSUURA 2003-04-30 13:13:02 UTC
Created attachment 91414 [details]
replacement of pxdvi.patch

Comment 7 Takanori MATSUURA 2003-04-30 13:13:51 UTC
Created attachment 91415 [details]
use autoconf213 for reautoconf

Comment 8 Takanori MATSUURA 2003-04-30 13:14:51 UTC
Created attachment 91416 [details]
modified patch of http://www.nn.iij4u.or.jp/~tutimura/tex/xdvik-22.40v-j1.17.patch.gz

Comment 9 Takanori MATSUURA 2003-04-30 13:15:50 UTC
Created attachment 91417 [details]
diff between original and my tetex.spec

Comment 10 Takanori MATSUURA 2003-04-30 13:18:16 UTC
Created attachment 91418 [details]
a patch for using Xaw3d in *xdvi

Comment 11 Tim Waugh 2003-05-08 08:28:20 UTC
Thanks.  Please take a look at 2.0.2-4 when it hits rawhide (soon).

Comment 12 Takanori MATSUURA 2003-05-16 14:17:33 UTC
OK. I tested tetex-2.0.2-4.

Here is some comments.
1. Is patch104 needed to tetex-2.0.2?
   (I suppose it is not needed. But I don't check the detail.)
2. about "XXX fix me - must be something wrong with .cnf file or file loading
   in pLaTeX"
     I think it is because $RPM_BUILD_DIR/tetex-2.0.2/texmf/ls-R is not
     refreshed when pLaTeX source is installed.

     To fix it, ls-R file should be deleted at build time.
     ("It is needed for installing another files in texmf" in my spec file.)

3. Almost all the Japanese users want mendexk: makeindex for Japanese :-)

Comment 13 Takanori MATSUURA 2003-05-16 14:21:22 UTC
Created attachment 91723 [details]
diff between original tetex-2.0.2-4 and my tetex.spec

This patch reflects #12


Note You need to log in before you can comment on or make changes to this bug.