Bug 894813 - Fix the default for libvirt_cpu_model so it works well when compute node is running in a VM
Fix the default for libvirt_cpu_model so it works well when compute node is r...
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
All Linux
medium Severity medium
: beta
: 5.0 (RHEL 7)
Assigned To: Solly Ross
Ami Jeain
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-13 14:46 EST by Perry Myers
Modified: 2015-06-04 17:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-09 08:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1100366 None None None Never

  None (edit)
Description Perry Myers 2013-01-13 14:46:18 EST
This can be done by detecting if compute node is running in a VM and automatically changing the cpu model vs. requiring a config file change
Comment 1 Stephen Gordon 2013-01-15 10:18:43 EST
Perry, is the current state that this doesn't work at all? Packstack allowed me to select the 'qemu' hypervisor (as opposed to kvm) but when I attempt to run instances I see this in libvirtd.log:

2013-01-15 03:15:19.927+0000: 1817: error : x86Decode:1399 : internal error Cannot find suitable CPU model for given data
2013-01-15 03:15:19.927+0000: 1817: warning : qemuCapsInit:848 : Failed to get host CPU

Is this the expected behaviour currently or a new/different bug?
Comment 2 Perry Myers 2013-01-15 10:21:54 EST
If you select qemu in PackStack it should configure your ComputeNodes to use fully emulated.  So what you encountered might be a different bug.

This bug is to remove the need for manually selecting qemu vs. kvm, and using some introspection for Nova to determine which to use automagically
Comment 3 Stephen Gordon 2013-01-15 10:46:47 EST
(In reply to comment #2)
> If you select qemu in PackStack it should configure your ComputeNodes to use
> fully emulated.  So what you encountered might be a different bug.

Digging further it looks like I've hit Bug # 895003. Nevermind me then ;).
Comment 5 Kashyap Chamarthy 2013-04-07 03:39:44 EDT
Tested on Fedora-19 -- https://bugs.launchpad.net/nova/+bug/1100366/comments/4
Comment 6 Solly Ross 2013-05-30 17:56:37 EDT
Proposed patch upstream: https://review.openstack.org/31133
Comment 7 Solly Ross 2014-04-08 17:37:47 EDT
The consensus upstream is that this (detection of CPU environment) is really something that should be going on at install time in Packstack, Foreman, etc.
Comment 8 Stephen Gordon 2014-04-09 08:36:56 EDT
(In reply to Solly Ross from comment #7)
> The consensus upstream is that this (detection of CPU environment) is really
> something that should be going on at install time in Packstack, Foreman, etc.

ACK, I'm OK with letting this slide. I don't think running nova-compute within a KVM guest is a use case we are actively concentrating on.

Note You need to log in before you can comment on or make changes to this bug.