Bug 894839 - Change Quantum DHCP agent to use RPC rather than notifications
Change Quantum DHCP agent to use RPC rather than notifications
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.0 (Folsom)
All Linux
medium Severity medium
: snapshot1
: 3.0
Assigned To: Gary Kotton
Ofer Blaut
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-13 15:12 EST by Perry Myers
Modified: 2016-04-26 10:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-quantum-2013.1.1-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 11:04:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-01-13 15:12:41 EST
Change Quantum DHCP agent to use RPC rather than notifications
Comment 1 Gary Kotton 2013-05-14 04:43:23 EDT
This is part of the Grizzly release.
Comment 4 Rami Vaknin 2013-05-23 15:58:50 EDT
Could you please specify what should be tested here? Does basic DHCP functionality imply that RPC works well?
Comment 5 Perry Myers 2013-05-26 10:29:27 EDT
(In reply to Rami Vaknin from comment #4)
> Could you please specify what should be tested here? Does basic DHCP
> functionality imply that RPC works well?

I'll have to defer to the Quantum devs to answer that question.
Comment 6 Gary Kotton 2013-05-26 12:31:48 EDT
The basic functionality of the DHCP service needs to be verified.

In Folsom when a subnet was created a notification would be sent and any DHCP agent could pick up the notification.

In Grizzly the agents are registered with the plugin and the communication is done directly with the agent via the standard RPC channels.
Comment 7 Rami Vaknin 2013-05-28 05:32:46 EDT
Verified on Grizzly installed on RHEL6.4, openstack-quantum-2013.1.1-8.el6ost.

The dnsmasq process has started successfully (after removing libvirt's dnsmasq process) and an instance got his ip.
Comment 9 errata-xmlrpc 2013-05-29 11:04:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0878.html

Note You need to log in before you can comment on or make changes to this bug.