Bug 894845 - Resolve issues with the metadata service not working with overlapping IP ranges in Quantum
Resolve issues with the metadata service not working with overlapping IP rang...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
All Linux
medium Severity medium
: snapshot2
: 3.0
Assigned To: Gary Kotton
yfried
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-13 15:17 EST by Perry Myers
Modified: 2016-04-27 01:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-quantum-2013.1.1-9.el6ost
Doc Type: Enhancement
Doc Text:
Support for the OpenStack networking metadata proxy has been added to the compute service. This resolves a previous issue with the use of the metadata service in combination with having overlapping IP ranges defined in OpenStack networking.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 14:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-01-13 15:17:25 EST
Resolve issues with the metadata service not working with overlapping IP ranges in Quantum
Comment 1 Dave Allan 2013-05-07 11:26:22 EDT
Gary, do you have any additional information about what's going on here?
Comment 2 Gary Kotton 2013-05-07 11:30:54 EDT
When Quantum supports overlapping IP's there was a problem with the metadata service. This was addressed upstream by adding in a proxy from Quantum to the metadata service.
Comment 3 Gary Kotton 2013-05-07 11:32:05 EDT
The support was added in the Grizzly cycle
https://blueprints.launchpad.net/quantum/+spec/metadata-overlapping-networks
Comment 4 Dave Allan 2013-05-29 21:58:54 EDT
(In reply to Gary Kotton from comment #3)
> The support was added in the Grizzly cycle
> https://blueprints.launchpad.net/quantum/+spec/metadata-overlapping-networks

Ok, I've moved this to POST since it should be in the builds now, if that's not correct, let me know.
Comment 7 yfried 2013-06-06 04:12:12 EDT
# rpm -qa | grep quan
openstack-quantum-2013.1.1-9.el6ost.noarch

# quantum net-list
+--------------------------------------+-------------+-----------------------------------------------------+
| id                                   | name        | subnets                                             |
+--------------------------------------+-------------+-----------------------------------------------------+
| 0ba825dc-8bd4-405c-9696-6429cdf82dfb | ext_net_181 | 937520ec-aa6b-46a2-b305-cd82cc7acaf7 10.35.166.0/24 |
| 8493539b-f795-442f-b591-103167ab172f | t2_net      | 4840c5c5-0597-403f-ac46-3ddc7a0885a3 10.0.0.0/24    |
| c7d4d7b7-804a-488a-ba50-e90dfbb6e18b | t1_net      | dbf71206-db95-4e5a-ae3a-e09a8d3c1759 10.0.0.0/24    |
+--------------------------------------+-------------+-----------------------------------------------------+

works from both tenants:
$ wget http://169.254.169.254
Connecting to 169.254.169.254 (169.254.169.254:80)
index.html           100% |*************************|    98   0:00:00 ETA
Comment 9 errata-xmlrpc 2013-06-11 14:54:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0936.html

Note You need to log in before you can comment on or make changes to this bug.