Bug 894878 - activeresource is no longer included in rails master at github.com/rails/rails
activeresource is no longer included in rails master at github.com/rails/rails
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: rubygem-activeresource (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mo Morsi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-13 17:08 EST by Allen Hewes
Modified: 2013-01-14 07:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 07:39:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen Hewes 2013-01-13 17:08:48 EST
Description of problem:
When following the directions in:
http://pkgs.fedoraproject.org/cgit/rubygem-activeresource.git/tree/rubygem-activeresource.spec

activeresource is no longer included in rails/master.

Version-Release number of selected component (if applicable):
I am not 100% sure, but I think this changed after 3.2.9 (the directions worked for me for 3.2.9)


How reproducible:
100%


Steps to Reproduce:
1.$ git clone http://github.com/rails/rails.git
Cloning into 'rails'...
remote: Counting objects: 346967, done.
remote: Compressing objects: 100% (87018/87018), done.
remote: Total 346967 (delta 269411), reused 332736 (delta 256773)
Receiving objects: 100% (346967/346967), 52.00 MiB | 3.90 MiB/s, done.
Resolving deltas: 100% (269411/269411), done.

2.cd rails/activeresource/
bash: cd: rails/activeresource/: No such file or directory

3.
  
Actual results:
$ git clone http://github.com/rails/rails.git
Cloning into 'rails'...
remote: Counting objects: 346967, done.
remote: Compressing objects: 100% (87018/87018), done.
remote: Total 346967 (delta 269411), reused 332736 (delta 256773)
Receiving objects: 100% (346967/346967), 52.00 MiB | 3.90 MiB/s, done.
Resolving deltas: 100% (269411/269411), done.

$ cd rails/activeresource/
bash: cd: rails/activeresource/: No such file or directory



Expected results:
$ git clone http://github.com/rails/rails -b 3-2-stable
Cloning into 'rails'...
remote: Counting objects: 346967, done.
remote: Compressing objects: 100% (87020/87020), done.
remote: Total 346967 (delta 269412), reused 332734 (delta 256771)
Receiving objects: 100% (346967/346967), 51.99 MiB | 4.24 MiB/s, done.
Resolving deltas: 100% (269412/269412), done.

$ cd rails/activeresource/

$ git checkout v3.2.11
Note: checking out 'v3.2.11'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

  git checkout -b new_branch_name

HEAD is now at 746dbd8... bumping version

$ tar czvf activeresource-3.2.11-tests.tgz test/
test/
test/setter_trap.rb
test/abstract_unit.rb
test/fixtures/
test/fixtures/customer.rb
test/fixtures/beast.rb
test/fixtures/street_address.rb
test/fixtures/sound.rb
test/fixtures/person.rb
test/fixtures/address.rb
test/fixtures/project.rb
test/fixtures/subscription_plan.rb
test/fixtures/proxy.rb
test/cases/
test/cases/finder_test.rb
test/cases/http_mock_test.rb
test/cases/base_errors_test.rb
test/cases/base/
test/cases/base/custom_methods_test.rb
test/cases/base/equality_test.rb
test/cases/base/load_test.rb
test/cases/base/schema_test.rb
test/cases/format_test.rb
test/cases/validations_test.rb
test/cases/base_test.rb
test/cases/observing_test.rb
test/cases/log_subscriber_test.rb
test/cases/authorization_test.rb
test/cases/connection_test.rb


Additional info:
This is very minor, but wanted to get this documented so that the notes in the spec file are accurate.
Comment 1 Vít Ondruch 2013-01-14 07:39:47 EST
Thank you for report. However, I am not going to change anything ATM, since the information is mostly true. We will definitely reconsider this issue as soon as we will migrate to Rails 4.

Note You need to log in before you can comment on or make changes to this bug.