Bug 89495 - Enable OpenOffice Render support with Xinerama enabled
Enable OpenOffice Render support with Xinerama enabled
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-04-23 11:19 EDT by Klaasjan Brand
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-16 16:36:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Klaasjan Brand 2003-04-23 11:19:05 EDT
Description of problem:

When running OpenOffice on a multi-head desktop with Xinerama enabled it will
turn off the Render support causing the fonts to look bad. Supposedly there's
some incompatibility between the Render and Xinerama extensions, but since I'm
running a complete Gnome2 desktop using both I guess the issues must have been
resolved in the meantime.

Additional info:

I've tracked this down to the openoffice source code, under
/vcl/unx/source/gdi/gcach_xpeer.cxx (line 136) there's a hard-coded hack to
disable xrender when xinerama is enabled, including the TODO to remove the hack
when there are no more problems.
Comment 1 Dan Williams 2004-09-16 16:36:35 EDT
Will get fixed when upstream fixes it.

Note You need to log in before you can comment on or make changes to this bug.