Bug 895097 - tomcat5 fails to start unless the supplementary repository is enabled in RHEL 5.9
Summary: tomcat5 fails to start unless the supplementary repository is enabled in RHEL...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tomcat5
Version: 5.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Knox
QA Contact: tomcat-qe
URL:
Whiteboard:
Depends On:
Blocks: 902429
TreeView+ depends on / blocked
 
Reported: 2013-01-14 14:57 UTC by Akemi Yagi
Modified: 2018-12-05 15:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 902429 (view as bug list)
Environment:
Last Closed: 2013-10-15 19:29:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CentOS 6186 0 None None None Never

Description Akemi Yagi 2013-01-14 14:57:57 UTC
Description of problem:
In RHEL 5.9, installing tomcat5 (tomcat5-5.5.23-0jpp.37.el5) pulls in java-1.7.0-ibm-devel (1:1.7.0.3.0-1jpp.2.el5) IF the supplementary-5 repository is enalbed. However, without the supplementary repo set up, tomcat5 pulls in java-1.4.2-gcj-compat-devel instead. In this case starting tomcat5 fails as seen in /var/log/tomcat5/catalina.out :

Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:
WARNING: error instantiating 'org.apache.juli.ClassLoaderLogManager' referenced by java.util.logging.manager, class not found
java.lang.ClassNotFoundException: org.apache.juli.ClassLoaderLogManager not found
   <<No stacktrace available>>
WARNING: error instantiating '1catalina.org.apache.juli.FileHandler,' referenced by handlers, class not found
java.lang.ClassNotFoundException: 1catalina.org.apache.juli.FileHandler,
   <<No stacktrace available>>
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NullPointerException
   <<No stacktrace available>>

Version-Release number of selected component (if applicable):
tomcat5-5.5.23-0jpp.37.el5

How reproducible: Always


Steps to Reproduce:
1. Install RHEL 5.9
2. Install tomcat5
3. service tomcat5 start
  
Actual results:
tomcat5 fails to start normally.

Expected results:
tomcat5 starts normally.

Additional info:
Installing java-1.6.0-openjdk-devel allows tomcat5 to start without any error.

Comment 2 Andrius Benokraitis 2013-10-15 19:29:13 UTC
No additional minor releases are planned for Production Phase 2 in Red Hat Enterprise Linux 5, and therefore Red Hat is closing this bugzilla as it does not meet the inclusion criteria as stated in:
https://access.redhat.com/site/support/policy/updates/errata/#Production_2_Phase


Note You need to log in before you can comment on or make changes to this bug.