Bug 8953 - Keyboard is generating an apostrophe every 112 seconds
Summary: Keyboard is generating an apostrophe every 112 seconds
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-29 00:05 UTC by bourdeau
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 02:45:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bourdeau 2000-01-29 00:05:45 UTC
I'll have to confirm my time measurement again, but here's the problem.

Exactly every 112 seconds, an IRQ 1 (which is my keyboard) is
generated and a backwards apostrophe ( ` ) is produced.  To
say this is annoying is an understatement.  This is not
related to X11 since the problem arises immediately on a
text login prior to even starting the X server.

On a separate partition I have Windows98 installed, and I have no
such problem with Windows and never have.

I have a Dell XPS R450 running an Intel PII chip, the keyboard
is "labelled" Dell Model SK-6000, it's a "natural keyboard".

Comment 1 bourdeau 2000-01-30 18:26:59 UTC
Correction to my frequency measurement.
The apostrophe is generated exactly every 64 seconds, give or take 1 second.

Comment 2 Cristian Gafton 2000-02-05 02:45:59 UTC
This is most definitely a hardware problem

Comment 3 bourdeau 2000-02-07 02:16:59 UTC
I can understand why this seems to be a hardware problem, but I'm not
entirely clear that this is actually the case.  Why is it that under
Windows I have no problems with my keyboard, spurious apostrophes, etc,
yet under Linux I have a perfectly timed interrupt being detected
every 64 seconds and translated into an apostrophe. I'm wondering
if my keyboard is sending some sort of "keep-alive" signal that my
windows drivers understand and ignore, but the Linux drivers do not?

There's almost no information on keyboards and their drivers so I
don't really know how to  further diagnose the problem.

Any suggestions would be appreciated. I'm confident this can work under
Linux if it works under the less-exciting operating system.`


Note You need to log in before you can comment on or make changes to this bug.