Bug 89535 - LTC2499-RH AS with 2.4.9-e16 - ps output makes user process look like kernel process
LTC2499-RH AS with 2.4.9-e16 - ps output makes user process look like kernel ...
Status: CLOSED DUPLICATE of bug 86569
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-23 17:16 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-04-23 17:16:33 EDT
Please fill in each of the sections below.

Hardware Environment:
x335

Software Environment:
RedHat Asvanced Server version 2.1, updated to latest errata

Steps to Reproduce:
1. Install RH AS 2.1
2. Upgrade to latest errata
3. type "ps -ef"

Actual Results: 

notice how user process like mysql and the customer's "pserver" are marked 
with [] in the "CMD" column.

UID        PID  PPID  C STIME TTY          TIME CMD
root         1     0  1 13:42 ?        00:00:04 init
root         2     1  0 13:42 ?        00:00:00 [keventd]
root         3     1  0 13:42 ?        00:00:00 [keventd]
root         4     1  0 13:42 ?        00:00:00 [keventd]
root         5     1  0 13:42 ?        00:00:00 [keventd]
root         6     0  0 13:42 ?        00:00:00 [ksoftirqd_CPU0]
root         7     0  0 13:42 ?        00:00:00 [ksoftirqd_CPU1]
root         8     0  0 13:42 ?        00:00:00 [ksoftirqd_CPU2]
root         9     0  0 13:42 ?        00:00:00 [ksoftirqd_CPU3]
root        10     0  0 13:42 ?        00:00:00 [kswapd]
root        11     0  0 13:42 ?        00:00:00 [kreclaimd]
root        12     0  0 13:42 ?        00:00:00 [krefilld]
root        13     0  0 13:42 ?        00:00:00 [bdflush]
root        14     0  0 13:42 ?        00:00:00 [kupdated]
root        15     1  0 13:42 ?        00:00:00 [mdrecoveryd]
root        24     1  0 13:42 ?        00:00:00 [kjournald]
root       102     1  0 13:42 ?        00:00:00 [khubd]
root       194     1  0 13:42 ?        00:00:00 [kjournald]
root       678     1  0 13:43 ?        00:00:00 /sbin/dhcpcd -n eth1
root       746     1  0 13:43 ?        00:00:00 syslogd -m 0
root       751     1  0 13:43 ?        00:00:00 klogd -2
rpc        771     1  0 13:43 ?        00:00:00 [portmap]
rpcuser    799     1  0 13:43 ?        00:00:00 [rpc.statd]
root       966     1  0 13:43 ?        00:00:00 /usr/sbin/sshd
root       999     1  0 13:43 ?        00:00:00 xinetd -stayalive -reuse -pidfil
root      1032     1  0 13:43 ?        00:00:00 /bin/sh /usr/bin/safe_mysqld --d
mysql     1072  1032  0 13:43 ?        00:00:00 [mysqld]
mysql     1075  1072  0 13:43 ?        00:00:00 [mysqld]
mysql     1076  1075  0 13:43 ?        00:00:00 [mysqld]
mysql     1088  1075  0 13:43 ?        00:00:00 [mysqld]
root      1089     1  0 13:43 ?        00:00:00 sendmail: accepting connections
root      1117     1  0 13:43 ?        00:00:00 [scsi_eh_1]
root      1136     1  0 13:43 ?        00:00:00 gpm -t ps/2 -m /dev/mouse
root      1154     1  0 13:43 ?        00:00:00 crond
xfs       1220     1  0 13:43 ?        00:00:00 [xfs]
daemon    1256     1  0 13:43 ?        00:00:00 [atd]
csps      1276     1  0 13:43 ?        00:00:00 [pserver]
mysql     1280  1075  0 13:43 ?        00:00:00 [mysqld]
csps      1284  1276  0 13:43 ?        00:00:00 [pserver]
csps      1285  1284  0 13:43 ?        00:00:00 [pserver]
mysql     1286  1075  0 13:43 ?        00:00:00 [mysqld]
csps      1287  1284  0 13:43 ?        00:00:00 [pserver]
mysql     1288  1075  0 13:43 ?        00:00:00 [mysqld]
csps      1291     1  0 13:43 ?        00:00:00 [licenseMgr]
csps      1292  1291  0 13:43 ?        00:00:00 [licenseMgr]
csps      1293  1292  0 13:43 ?        00:00:00 [licenseMgr]
csps      1303     1  0 13:43 ?        00:00:00 [spa]
csps      1307     1  0 13:43 ?        00:00:00 /usr/local/sip/bin/Sip_Services 
csps      1315  1303  0 13:43 ?        00:00:00 [spa]
csps      1316  1315  0 13:43 ?        00:00:00 [spa]
csps      1326     1  0 13:43 ?        00:00:00 [sipd]


Expected Results:

Additional Information:
 
Here's my proc/x/status for the master sipd and pserver processes.  
They are listed as sleeping, but are not all 'f's.  The other commands 
requested are in the attached file.  Please note that we have both the 
2.4.9-e3 kernel and the 2.4.9-e16 kernels installed.  Booting under e3 
works properly.  The debugs are from the e16 kernel.

root@faye ~]# cat /proc/1326/status
Name:   sipd
State:  S (sleeping)
Pid:    1326
PPid:   1
TracerPid:      0
Uid:    501     501     501     501
Gid:    501     501     501     501
TGid:   1326
FDSize: 32
Groups:
VmSize:   258296 kB
VmLck:         0 kB
VmRSS:    255148 kB
VmData:     1824 kB
VmStk:        92 kB
VmExe:      1236 kB
VmLib:      4424 kB
SigPnd: 0000000000000000
SigBlk: 0000000080000000
SigIgn: 8000000000001000
SigCgt: 000000038800446b
CapInh: 0000000000000000
CapPrm: 0000000000000000
CapEff: 0000000000000000
[root@faye ~]# cat /proc/1276/status
Name:   pserver
State:  S (sleeping)
Pid:    1276
PPid:   1
TracerPid:      0
Uid:    501     501     501     501
Gid:    501     501     501     501
TGid:   1276
FDSize: 32
Groups:
VmSize:    15824 kB
VmLck:         0 kB
VmRSS:      2980 kB
VmData:    10888 kB
VmStk:        44 kB
VmExe:      1260 kB
VmLib:      3172 kB
SigPnd: 0000000000000000
SigBlk: 0000000080000000
SigIgn: 8000000000001000
SigCgt: 0000000380014001
CapInh: 0000000000000000
CapPrm: 0000000000000000
CapEff: 0000000000000000


Current relevant packages installed:
-------------------------------------
kernel-source-2.4.9-e.16
kernel-2.4.9-e.3
kernel-utils-2.4-6
kernel-smp-2.4.9-e.3
kernel-doc-2.4.9-e.16
kernel-smp-2.4.9-e.16
kernel-headers-2.4.9-e.16
kernel-debug-2.4.9-e.16
kernel-debug-2.4.9-e.3
kernel-pcmcia-cs-3.1.27-10
kernel-2.4.9-e.16
glibc-common-2.2.4-31.7
glibc-profile-2.2.4-31.7
libcap-1.10-6
dietlibc-0.15-1.9
glibc-devel-2.2.4-31.7
compat-glibc-6.2-2.1.3.2
glibc-2.2.4-31.7
libcap-devel-1.10-6
procps-X11-2.0.7-11
procps-2.0.7-11
Comment 1 Arjan van de Ven 2003-04-24 04:50:37 EDT
not being allowed to see detailed information about security sensitive processes
is a known sideeffect of the ptrace security hardening patches

*** This bug has been marked as a duplicate of 86569 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.