Bug 89541 - No support for IP addresses
No support for IP addresses
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: pam_smb (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-23 20:40 EDT by Mike Papper
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:54:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch. Allows to specify IP in /etc/pam_smb.conf file (20.32 KB, patch)
2003-04-23 20:43 EDT, Mike Papper
no flags Details | Diff
Source RPM with Patch for adding IP addresses for resolving PDCs (74.66 KB, application/octet-stream)
2003-04-23 20:46 EDT, Mike Papper
no flags Details
Patch file that inlcudes reading of optional /etc/pam_snb_ip.conf config file (21.55 KB, patch)
2003-04-28 13:31 EDT, Mike Papper
no flags Details | Diff
SRPM for pam_smb patch to provide cofiguration of IP addresses for DomainServers (76.22 KB, application/octet-stream)
2003-04-28 13:33 EDT, Mike Papper
no flags Details

  None (edit)
Description Mike Papper 2003-04-23 20:40:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030212

Description of problem:
On some networks, the Windows PDC is not reachable/resolvable through its
NetBios Computer Name. 

Using just the PDC IP address in the conf file does not work for Windows NT4 PDC
machines. It does work for linux machines running samba.

One solution is to map the NetBios name to an IP address in the /etc/hosts file.
To avoid this addition, I added an option to the pam_smb configuration file so
that it will accepts addiitonal IP address arguments.

For each NetBios name, the config file can also contain a corresponding IP
address. This IP address will be used if it is non-blank to make the connection
with the Windows Domain Controller. These IP addresses must be specified as the
fourth and fifthlines of the /etc/pam_smb.conf file.

Note that many Windows PDCs will not work with this module if the NetBios name
is not supplied (i.e., if we supply an IP address instead of the NetBios name,
it will not be able to contact the Windows machine).

Version-Release number of selected component (if applicable):
pam_smb-1.1.6-5

How reproducible:
Always

Steps to Reproduce:
1.Contact an actual Windows NT4 PDC (not a linux machine running Samba)
2.Make sure there is no DNS entry for the chosen NetBios name
3.Turn off NMBLookups on the machine running the pam_smb module.

I.E., put an entry in the /etc/pam_smb.conf file that is not resolvable.
    

Actual Results:  The machine does not attempt to contact the PDC. Authentication
fails.

Expected Results:  The machine should be able to easily specify the IP address
of the PDC. This coul;d be done in the /etc/pam_smb.conf file. Alternativly the
module could do an nmblookup itself to resolve the NetBios name to the IP
address of the PDC.

Additional info:

We have edited the source code to accept an IP address for the primary and
secondary PDCs (as specified in the /etc/pam_smb.conf file).

The patched is/will be attached to this bug.
Comment 1 Mike Papper 2003-04-23 20:43:33 EDT
Created attachment 91265 [details]
Patch. Allows to specify IP in /etc/pam_smb.conf file

Please see README in patch for a tiny bit more info.
Comment 2 Mike Papper 2003-04-23 20:46:27 EDT
Created attachment 91266 [details]
Source RPM with Patch for adding IP addresses for resolving PDCs

New Source RPM with Patch included. Note that we did not chnage the version
number (oops).
Comment 3 Mike Papper 2003-04-28 13:29:05 EDT
It appears that editing the format of the /etc/pam_smb.conf file is a bad idea 
because the authconfig program will also edit this file and remove the extra 
lines #4 and #5.

To get around this, the code I added to the pam_smb module now optionally reads 
another config file called /etc/pam_smb_ip.conf. Init are 2 lines, holding the 
IP addresses corresponding to the netbios names from /etc/pam_smb.conf.

Note that the extra ocnfig file is optional.
Comment 4 Mike Papper 2003-04-28 13:31:24 EDT
Created attachment 91341 [details]
Patch file that inlcudes reading of optional /etc/pam_snb_ip.conf config file

Provides for use of IP addresses to find Windows Domain Servers via their IP
addresses. Info is in a config filenamed /etc/pam_smb_ip.conf.
Comment 5 Mike Papper 2003-04-28 13:33:47 EDT
Created attachment 91342 [details]
SRPM for pam_smb patch to provide cofiguration of IP addresses for DomainServers

Source RPM with updated version (from 1.1.6-5 to 1.1.6-6) including patch to
read config file named /etc/pam_smb_ip.conf which holds IP addresses of windows
domain servers.
Comment 6 Bill Nottingham 2006-08-07 13:52:27 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 7 Bill Nottingham 2006-10-18 10:54:09 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.