Bug 89547 - When I try to compile perl-MD5 it does not compile.
When I try to compile perl-MD5 it does not compile.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: perl-Digest-MD5 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-24 02:31 EDT by Andre Kruger
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-22 19:22:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the make file that is generated by perl Makefile.PL (22.73 KB, text/plain)
2003-04-24 02:35 EDT, Andre Kruger
no flags Details

  None (edit)
Description Andre Kruger 2003-04-24 02:31:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
[root@jabba Digest-MD5-2.24]# pwd
/root/.cpan/build/Digest-MD5-2.24
[root@jabba Digest-MD5-2.24]# perl Makefile.PL
Testing alignment requirements for U32... no restrictions
Checking if your kit is complete...
Looks good
Writing Makefile for Digest::MD5
[root@jabba Digest-MD5-2.24]# make
Makefile:83: *** missing separator.  Stop.
[root@jabba Digest-MD5-2.24]#


Version-Release number of selected component (if applicable):
Digest-MD5-2.24

How reproducible:
Always

Steps to Reproduce:
1.perl -MCPAN -e 'install Digest::MD5'
2.
3.
    

Actual Results:  [root@jabba root]# perl -MCPAN -e 'install Digest::MD5'
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
  Database was generated on Wed, 23 Apr 2003 21:14:18 GMT
Running install for module Digest::MD5
Running make for G/GA/GAAS/Digest-MD5-2.24.tar.gz
CPAN: Digest::MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for /root/.cpan/sources/authors/id/G/GA/GAAS/Digest-MD5-2.24.tar.gz ok
Scanning cache /root/.cpan/build for sizes
Deleting from cache: /root/.cpan/build/Bundle-libnet-1.00 (11.8>10.0 MB)
Deleting from cache: /root/.cpan/build/DBI-1.35 (11.8>10.0 MB)
Digest-MD5-2.24/
Digest-MD5-2.24/t/
Digest-MD5-2.24/t/files.t
Digest-MD5-2.24/t/md5-aaa.t
Digest-MD5-2.24/t/align.t
Digest-MD5-2.24/t/clone.t
Digest-MD5-2.24/t/utf8.t
Digest-MD5-2.24/t/badfile.t
Digest-MD5-2.24/hints/
Digest-MD5-2.24/hints/irix_6.pl
Digest-MD5-2.24/hints/MacOS.pl
Digest-MD5-2.24/hints/dec_osf.pl
Digest-MD5-2.24/Changes
Digest-MD5-2.24/MANIFEST
Digest-MD5-2.24/rfc1321.txt
Digest-MD5-2.24/typemap
Digest-MD5-2.24/README
Digest-MD5-2.24/MD5.pm
Digest-MD5-2.24/MD5.xs
Digest-MD5-2.24/Makefile.PL
Removing previously used /root/.cpan/build/Digest-MD5-2.24
 
  CPAN.pm: Going to build G/GA/GAAS/Digest-MD5-2.24.tar.gz
 
Testing alignment requirements for U32... no restrictions
Checking if your kit is complete...
Looks good
Writing Makefile for Digest::MD5
Makefile:83: *** missing separator.  Stop.
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible
[root@jabba root]#


Expected Results:  Digest::MD5 properly installed.

Additional info:

This problem came about when I executed this 

perl -MCPAN -e 'install Bundle::Interchange'


I will attach the Makefile that is generated ... it looks like it is missing
quotation marks and maybe some charachters.

I have reproduced this on two seperate machines.
Comment 1 Andre Kruger 2003-04-24 02:35:17 EDT
Created attachment 91269 [details]
This is the make file that is generated by perl Makefile.PL

If you need any more information just yell.
Comment 2 Warren Togami 2005-07-22 19:22:56 EDT
Arbitrary 3rd party software or stuff from CPAN is not our responsibility. 
Furtheremore there are many modern packages of this that work fine.

Note You need to log in before you can comment on or make changes to this bug.