Bug 895586 - RFE: Display more information on cause of instance error state on UI
RFE: Display more information on cause of instance error state on UI
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.1
Unspecified Unspecified
low Severity low
: Upstream M1
: 5.0 (RHEL 7)
Assigned To: Julie Pichon
Amit Ugol
: FutureFeature, Triaged
: 1033141 (view as bug list)
Depends On: 891051 895588
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 10:27 EST by Stephen Gordon
Modified: 2016-04-26 15:28 EDT (History)
11 users (show)

See Also:
Fixed In Version: python-django-horizon-2014.1-4.el7ost
Doc Type: Enhancement
Doc Text:
Previously, when the status of an instance updated to 'Error', there was no feedback displayed on the UI. With this update, information about the error displayed for 'nova show [instance_id]' is displayed on the Instance Details UI page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 11:42:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pic (25.53 KB, image/jpeg)
2014-06-19 01:23 EDT, Amit Ugol
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1236168 None None None Never
Launchpad 1255391 None None None Never
OpenStack gerrit 49988 None None None Never
OpenStack gerrit 58682 None None None Never

  None (edit)
Description Stephen Gordon 2013-01-15 10:27:56 EST
Description of problem:

When creating an instance fails no user-actionable feedback is displayed in the UI. 

- The status of the instance updates to "Error".
- Clicking through to the instance overview yields no additional information.
- Clicking the logs tab yields no logs.

As a result when an instance fails to start the user's only recourse is to head to the command line and use nova show (and even that is a bit of a hit and miss affair, see Bug #891051).

The cause for the failure to create the instance should be made visible via the UI.
Comment 1 Julie Pichon 2013-05-07 13:57:10 EDT
Agreed, although Horizon can only display whatever information is returned by the nova API.
Comment 2 Stephen Gordon 2013-05-07 14:18:19 EDT
(In reply to comment #1)
> Agreed, although Horizon can only display whatever information is returned
> by the nova API.

My understanding based on the below is that some more information to this end is available from Nova in Grizzly:

https://bugzilla.redhat.com/show_bug.cgi?id=891051#c4
Comment 3 Julie Pichon 2013-10-09 05:33:22 EDT
As part of launchpad bug 1236168 (merged in Icehouse M1), Horizon now shows an error message when failing to launch an instance (what you would get with 'nova show'). We probably still want to at least add this info to the Instances Details page, though.
Comment 4 Julie Pichon 2013-11-27 05:38:07 EST
*** Bug 1033141 has been marked as a duplicate of this bug. ***
Comment 5 Julie Pichon 2013-12-05 07:09:28 EST
Note the previously linked patch was merged into Icehouse-1 and adds information about the error to the Instance Details page (as shown by `nova show <instance id>`).
Comment 6 Jeff Dexter 2014-05-07 11:40:23 EDT
Attaching sfdc ticket 01080752 to track when RFE is complete
Comment 7 Julie Pichon 2014-05-27 06:08:54 EDT
This should already be available in the current RHEL OSP 5 packages, updating status.
Comment 8 Amit Ugol 2014-06-19 01:23:41 EDT
Created attachment 910250 [details]
pic
Comment 9 Amit Ugol 2014-06-19 01:24:14 EDT
verified on python-django-horizon-2014.1-7.el7ost.noarch.
curreent error shows the short description + the http error code + related error.
Comment 11 errata-xmlrpc 2014-07-08 11:42:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0855.html

Note You need to log in before you can comment on or make changes to this bug.