Bug 895588 - RFE: Improve granularity of "NoValidHost" error.
RFE: Improve granularity of "NoValidHost" error.
Status: CLOSED DUPLICATE of bug 891051
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 3.0
Assigned To: Russell Bryant
Ami Jeain
https://blueprints.launchpad.net/nova...
: FutureFeature, Triaged
Depends On:
Blocks: 895586
  Show dependency treegraph
 
Reported: 2013-01-15 10:32 EST by Stephen Gordon
Modified: 2016-04-26 12:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 11:56:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-01-15 10:32:43 EST
Description of problem:

It appears that the NoValidHost error can occur for a variety of reasons:

- No hosts are available at all.
- No hosts with appropriate CPU(s) available.
- No hosts with required RAM available.
- No hosts with required disk available.
- All of the above?
- Others?

Users who have experience with other compute solutions, particularly more traditional virtualization solutions, expect the error returned in these situations to be more granular and attempt to pin down *why* no host was considered valid.
Comment 1 Russell Bryant 2013-01-15 11:30:23 EST
Upstream blueprint exists for this, good progress is being made toward getting this merged for grizzly: https://blueprints.launchpad.net/nova/+spec/instance-actions
Comment 2 Perry Myers 2013-02-15 14:35:57 EST
@rbryant: The upstream blueprint is targeted for G-3.  Is this a candidate for backport or too invasive/risky?
Comment 3 Russell Bryant 2013-02-15 16:28:36 EST
It requires a db migration, so I don't think it's a candidate for being backported.  I've bumped this to 3.0.
Comment 4 Dave Allan 2013-04-30 12:08:42 EDT
Russell, this is done, right?
Comment 6 Dave Allan 2013-06-03 11:56:37 EDT

*** This bug has been marked as a duplicate of bug 891051 ***

Note You need to log in before you can comment on or make changes to this bug.