Bug 89574 - gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-1) is broken
gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-1) is broken
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-24 10:55 EDT by hjl
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-24 14:16:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hjl 2003-04-24 10:55:33 EDT
gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-1) is broken on
ia64. I got

if [ x"-fpic" != x ]; then \
  /export/build/gnu/gcc-3.2-redhat-8/build-ia64-linux/gcc/xgcc
-B/export/build/gnu/gcc-3.2-redhat-8/build-ia64-linux/gcc/
-B/usr/gcc-3.2-redhat-8/ia64-unknown-linux-gnu/bin/
-B/usr/gcc-3.2-redhat-8/ia64-unknown-linux-gnu/lib/ -isystem
/usr/gcc-3.2-redhat-8/ia64-unknown-linux-gnu/include -c -DHAVE_CONFIG_H -O2 -g
-O2 -I. -I/net/gnu/export/gnu/src/gcc-3.2-redhat-8/gcc/libiberty/../include  -W
-Wall
-Wtraditional -pedantic -fpic
/net/gnu/export/gnu/src/gcc-3.2-redhat-8/gcc/libiberty/regex.c -o pic/regex.o; \
else true; fi
In file included from
/net/gnu/export/gnu/src/gcc-3.2-redhat-8/gcc/include/xregex.h:26,
                 from
/net/gnu/export/gnu/src/gcc-3.2-redhat-8/gcc/libiberty/regex.c:195:
/net/gnu/export/gnu/src/gcc-3.2-redhat-8/gcc/include/xregex2.h:551: warning: ISO
C89 does not support `static' or type qualifiers in parameter array
declarators/net/gnu/export/gnu/src/gcc-3.2-redhat-8/gcc/libiberty/regex.c: In
function `init_syntax_once':
/net/gnu/export/gnu/src/gcc-3.2-redhat-8/gcc/libiberty/regex.c:289: Internal
compiler error in gen_rtx_SUBREG, at emit-rtl.c:471
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[4]: *** [regex.o] Error 1
make[4]: Leaving directory
`/export/build/gnu/gcc-3.2-redhat-8/build-ia64-linux/ia64-unknown-linux-gnu/libiberty'
make[3]: *** [all-target-libiberty] Error 2
make[3]: Leaving directory
`/export/build/gnu/gcc-3.2-redhat-8/build-ia64-linux'make[2]: *** [bootstrap]
Error 2
make[2]: Leaving directory
`/export/build/gnu/gcc-3.2-redhat-8/build-ia64-linux'Command exited with
non-zero status 2
9535.26user 126.66system 2:43:54elapsed 98%CPU (0avgtext+0avgdata
0maxresident)k0inputs+0outputs (1708036major+2672076minor)pagefaults 0swaps
make[1]: *** [bootstrap] Error 2

gcc version 3.2.2 20030407 (Red Hat Linux 3.2.2-17) is ok on ia64.
Comment 1 Jakub Jelinek 2003-04-24 12:51:57 EDT
Is it that you cannot bootstrap or something else?
I certainly bootstrapped just fine when building it on IA-64.
Can you please attach preprocessed source which this fails on and exact
arguments? I'll have a look if I can reproduce it on my IA-32 box in a cross...
I certainly don't remember any changes which could be relevant to this recently,
maybe something merged from gcc-3_2-branch...
Comment 2 hjl 2003-04-24 13:17:39 EDT
I can't bootstrap. A small testcase

# cat regex.c
int
foo (int c)
{
  return c & 0x7f;
}
# ./xgcc -B./ -O2 /tmp/regex.c -S
/tmp/regex.c: In function `foo':
/tmp/regex.c:4: Internal compiler error in gen_rtx_SUBREG, at emit-rtl.c:471
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Comment 3 Jakub Jelinek 2003-04-24 14:16:10 EDT
This must be a problem on your side. Cannot reproduce this on a fully bootstrapped
gcc-3.2.3-1 on ia64 native nor in i386 -> ia64 cross.

Note You need to log in before you can comment on or make changes to this bug.