This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 895797 - HMP monitor hang and qemu fail to general EIO when disconnect the NFS server
HMP monitor hang and qemu fail to general EIO when disconnect the NFS server
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 21:29 EST by Sibiao Luo
Modified: 2013-12-06 12:23 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 12:23:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-01-15 21:29:51 EST
Description of problem:
Configure the NFS and mount it, boot a guest with a data disk located on NFS storage, disconnect the NFS server during some I/O to the data disk in guest, then resume the paused guest by running "cont" in monitor after reconnect NFS server. But HMP monitor hang, qemu fail to general EIO when disconnect the NFS server, the geust kernel log output some 'sd 3:0:0:0: [sdb] abort'.
BTW, the rhel6 host have no such issue.

Version-Release number of selected component (if applicable):
host info:
kernel-3.6.0-0.29.el7.x86_64
qemu-kvm-1.3.0-3.el7.x86_64
nfs-utils-1.2.6-11.el7.x86_64
guest info:
rhel6.4
kernel-2.6.32-353.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.configure the NFS and mount it.
# cat /etc/exports 
/home *(rw,no_root_squash,sync)
# mount -o soft,timeo=15,retrans=3,nosharecache $nfs_server_ip:/home/ /mnt/
2.boot a guest with a data disk(werror=stop,rerror=stop) located on NFS storage.
e.g:...-drive file=/mnt/my-data-disk.qcow2,if=none,id=drive-data-disk,format=qcow2,aio=native,cache=none,werror=stop,rerror=stop -device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=0x8 -device scsi-hd,drive=drive-data-disk,bus=scsi1.0,id=data-disk
3.disconnect the NFS server during some I/O to the data disk in guest.
# service nfs stop
4.reconnect NFS server.
# service nfs restart
5.resume the paused guest by running "cont" in monitor.

Actual results:
after step 3, the guest and HMP monitor just hang there, can't do any action in HMP monitor and fail to general EIO, the geust kernel log output many 'sd 3:0:0:0: [sdb] abort', like:
...
sd 3:0:0:0: [sdb] abort
sd 3:0:0:0: [sdb] abort
sd 3:0:0:0: [sdb] abort
sd 3:0:0:0: [sdb] abort
sd 3:0:0:0: [sdb] abort
sd 3:0:0:0: [sdb] abort
sd 3:0:0:0: [sdb] abort
sd 3:0:0:0: [sdb] abort

...

Expected results:
qemu general EIO successfully, the VM was in paused status without any hang, and the guest kernel log do not prompt any abort.
(qemu) block I/O error in device 'drive-data-disk': Input/output error (5)
block I/O error in device 'drive-data-disk': Input/output error (5)
block I/O error in device 'drive-data-disk': Input/output error (5)
block I/O error in device 'drive-data-disk': Input/output error (5)
...
(qemu) info status
VM status: paused (io-error)

Additional info:
Comment 1 Sibiao Luo 2013-01-15 22:14:56 EST
btw, i also tried the virtio_blk data disk, the HMP not hang, but the QEMU did not general EIO.
Comment 3 Hai Huang 2013-02-12 13:40:09 EST
Behavior appears to be specific to virtio-scsi (and not with virtio-blk). 
Please feel free to reassign this BZ as appropriate. Thanks.
Comment 4 Sibiao Luo 2013-07-31 06:48:49 EDT
virtio-blk, virtio-scsi and ide interface, all of them can hit this issue.
Comment 5 Ademar Reis 2013-12-06 12:23:22 EST
This is related to bug 665820 and as discussed there, this is very difficult to implement.

Anyway, I'm closing this bug because HMP is not going to be supported in RHEL7.

Note You need to log in before you can comment on or make changes to this bug.