Bug 89583 - mga driver delivers broken DVI output for G550 (no picture).
mga driver delivers broken DVI output for G550 (no picture).
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82777
  Show dependency treegraph
 
Reported: 2003-04-24 12:16 EDT by Axel Thimm
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 08:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log output for Red Hat supplied mga drivers. (31.72 KB, text/plain)
2003-04-28 07:11 EDT, Axel Thimm
no flags Details
XFree86 log output for Matrox supplied mga drivers (built for 4.2.x). (31.86 KB, text/plain)
2003-04-28 07:12 EDT, Axel Thimm
no flags Details
double submission (user error) (31.72 KB, text/plain)
2003-04-28 07:23 EDT, Axel Thimm
no flags Details

  None (edit)
Description Axel Thimm 2003-04-24 12:16:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030407

Description of problem:
The mga driver as shipped in Red Hat Linux 9/Xfree86 4.3
does not cope well with DVI monitors at resolutions higher than 1024x768.

Card: G550
Display: EIZO Flexscan L461

Videocard DDC probe results
Description:  Matrox G550
Memory (MB):  32

Monitor DDC probe results
ID: ENC1628
Name: L461
Horizontal Sync (kHZ): 30-65
Vertical Sync (HZ)  : 59-61
Width (mm): 320
Height(mm): 250


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure XF86Config with a resolution of 1280x1024.
2.
3.
    

Actual Results:  The signal is delivered at 30Hz instead of 60Hz. The display
refuses to show anything.

Expected Results:  The signal should have been delivered at 60Hz.

Additional info:

This seems to be due to the lack of a module called mga_hal, which is not
shipped with Red Hat Linux 9.

It is available at matrox' support pages, but only for XFree86 up to 4.2.1, and
does not compile against Xfree86 in Red Hat 9 or in rawhide (The build requires
some missing headers, e.g. mga_common.h).
Comment 1 Mike A. Harris 2003-04-28 06:29:05 EDT
>This seems to be due to the lack of a module called mga_hal, which is not
>shipped with Red Hat Linux 9.

Actually, it has nothing to do with Matrox's hallib.  Matrox hallib is a
proprietary driver plugin which is intentionally not shipped with Red Hat
Linux, as we ship only open source drivers, which hallib is not.

>It is available at matrox' support pages, but only for XFree86 up to 4.2.1, and
>does not compile against Xfree86 in Red Hat 9 or in rawhide (The build requires
>some missing headers, e.g. mga_common.h).

You'll have to contact Matrox directly for any support problems if you're using
their hallib.  We do not support it at all.

Using the mga driver that ships with Red Hat Linux please attach your
X server log and config file as individual file attachments to the bug
report using the link below.  Make sure you are using the mga driver that
comes with Red Hat Linux, and not Matrox's hallib.

Thanks.
Comment 2 Axel Thimm 2003-04-28 07:08:37 EDT
> > This seems to be due to the lack of a module called mga_hal, which is not
> > shipped with Red Hat Linux 9.
> Actually, it has nothing to do with Matrox's hallib.  Matrox hallib is a
> proprietary driver plugin which is intentionally not shipped with Red Hat
> Linux, as we ship only open source drivers, which hallib is not.

Quoting from XFree86' man page to mga(4x):
> Support for [something else] requires a binary-only "mga_hal" module [...].
> That module also provides various other enhancements, and may be necessary
> to use the DVI (digital) output on the G550 (and other cards).

Similar information can be found on Mandrake's bug tracing system. I copied the
Matrox drivers (built for 4.2.0) over the ones provided in the XFree86 rpm, and
the output works now.

I had already tried to contact Matrox (in Germany) and they diverted me to a
user forum.

I will attach the log outputs of the non working RH9 version and the working
built-for-4.2.0 Matrox version. I don't see any interesting difference myself.
Comment 3 Axel Thimm 2003-04-28 07:11:21 EDT
Created attachment 91333 [details]
XFree86 log output for Red Hat supplied mga drivers.
Comment 4 Axel Thimm 2003-04-28 07:12:30 EDT
Created attachment 91334 [details]
XFree86 log output for Matrox supplied mga drivers (built for 4.2.x).
Comment 5 Axel Thimm 2003-04-28 07:23:43 EDT
Created attachment 91335 [details]
double submission (user error)
Comment 6 Axel Thimm 2003-04-28 07:26:57 EDT
Comment on attachment 91335 [details]
double submission (user error)

sorry, pressed back with postdata ... :(
Comment 7 Mike A. Harris 2003-04-28 08:53:50 EDT
Ah, I haven't kept up with the mga manpage, and didn't realize the mga
hallib was required for DVI output.  In this case, DVI output is not
supported by Red Hat, since we do not support or ship Matrox hallib,
and have no intentions of doing so.

When XFree86 gets open source support for this mode of operation, and it
is included in a future XFree86.org official XFree86 release, it will
get included in a future Red Hat Linux release.  If you become aware of
such support being included in XFree86 CVS in the future, feel free to
poke at me to investigate it, and if it is clean code I can consider
backporting it to 4.3.0 possibly.

Closing as NOTABUG as there's no NOT_SUPPORTED bugzilla option.


Note You need to log in before you can comment on or make changes to this bug.