Bug 896018 - GStreamer will not be able to install mp3 plugin using packagekit
Summary: GStreamer will not be able to install mp3 plugin using packagekit
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer1-plugins-base
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-16 13:43 UTC by Christian Fredrik Kalager Schaller
Modified: 2013-01-23 01:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-23 01:59:21 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 681362 None None None Never

Description Christian Fredrik Kalager Schaller 2013-01-16 13:43:24 UTC
There is a patch from Bastien Nocera in the external GNOME bug linked. We should apply that to our gstreamer packages for the time being until a permanent solution can be found.

Comment 1 Brian Pepple 2013-01-19 22:04:23 UTC
Applied Bastien's patch(1), but testing it locally, it appears mp3 codec discovery is still broken, with the following info being given:

** Message: Missing plugin: gstreamer|1.0|totem|MPEG-1 Layer 3 (MP3) decoder|decoder-audio/mpeg, mpegversion=(int)1, layer=(int)3, parsed=(boolean)true (MPEG-1 Layer 3 (MP3) decoder)
** Message: PackageKit: xid = 41943051
** Message: PackageKit: Codec nice name: MPEG-1 Layer 3 (MP3) decoder
** Message: PackageKit: ignoring field named parsed
** Message: PackageKit: field is: mpegversion, type: gint
** Message: PackageKit: field is: layer, type: gint
** Message: PackageKit: structure: gstreamer1.0(decoder-audio/mpeg)(mpegversion=1)(layer=3)
** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.PackageKit.Modify.NoPackagesFound: failed to find codec
** Message: No installation candidate for missing plugins found.

I didn't rebuild the gst1-plugins-ugly package when I did my test, but when I get home from FUDCon I'll see if that is the problem.

(1) http://koji.fedoraproject.org/koji/buildinfo?buildID=379373

Comment 2 Brian Pepple 2013-01-19 23:42:15 UTC
(In reply to comment #1)
> Applied Bastien's patch(1), but testing it locally, it appears mp3 codec
> discovery is still broken, with the following info being given:
<snip> 
> (1) http://koji.fedoraproject.org/koji/buildinfo?buildID=379373

Ok, disregard. I forgot to update my PackageKit for hughsie's latest build. Once I install that mp3 discovery works like it should. I'll be submitting the build to Bodhi shortly.

Comment 3 Fedora Update System 2013-01-20 03:38:43 UTC
gstreamer1-plugins-bad-free-1.0.5-1.fc18, gstreamer1-plugins-good-1.0.5-1.fc18, gstreamer1-1.0.5-1.fc18, empathy-3.6.3-1.fc18, gstreamer1-plugins-base-1.0.5-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-0543/gstreamer1-plugins-base-1.0.5-2.fc18,empathy-3.6.3-1.fc18,gstreamer1-plugins-bad-free-1.0.5-1.fc18,gstreamer1-plugins-good-1.0.5-1.fc18,gstreamer1-1.0.5-1.fc18

Comment 4 Christian Fredrik Kalager Schaller 2013-01-20 08:31:03 UTC
I should have mentioned that, there was also a general issue with the script generating the provides and pkgkit doing versioning of 1.0 differently. So pkgkit looks for gstreamer1.0, but the script just does gstreamer1. Richard H. is pushing an updated pkgkit that can deal with both.

Comment 5 Fedora Update System 2013-01-23 01:59:22 UTC
gstreamer1-plugins-bad-free-1.0.5-1.fc18, gstreamer1-plugins-good-1.0.5-1.fc18, gstreamer1-1.0.5-1.fc18, empathy-3.6.3-1.fc18, gstreamer1-plugins-base-1.0.5-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.