Bug 89645 - Errors in GSG
Errors in GSG
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhl-gsg (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Ha
John Ha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-25 10:01 EDT by Miloslav Trmac
Modified: 2014-08-04 18:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-30 14:28:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2003-04-25 10:01:28 EDT
Section 1.1
"adjusts the clock on your computer's BIOS (Basic Input Output System)"
Technically incorrect. BIOS is a *program* responsible for booting,
providing basic services and offering the Setup inteface.

The real time is stored in a real-time-clock chip, which is usually
(but also techincally incorrectly ;-) referred to as CMOS. Nowadays,
this "chip" is probably integrated in the chipset somewhere.


Section 16.8
Instead of select image, 'e', select kernel, 'e', edit, Enter, 'b'
it is enouth to select image, 'a', edit, Enter
(this is a RHL-specific feature IIRC).


Section 16.9
This works only when logged in as root.


Appendix E
"Ctrl-L" clears the terminal only in bash.
In most text-mode applications, Ctrl-L means "redraw the screen", usually
because it was corrupted by a 'write', 'talk' or something like that.
Comment 1 John Ha 2003-04-29 17:49:00 EDT
Thank you for your report. I am investigating your findings and will report back
shortly.
Comment 2 John Ha 2003-04-30 12:47:22 EDT
Thank you for your patience. Here are the results of my findings:

1) Since the system clock is adjustable in the BIOS, the text was aiming to give
some contrast to time and date configuration to illustrate the ease of using the
'Time and Date' function in the Setup Agent rather than entering BIOS setup to
do it.

I will amend the text to read "The Setup Agent allows you to manually adjust the
date and time for your system" to alleviate any confusion for new users.

2) You make an excellent point. Not only does your method involve fewer steps,
it feels much safer (and less invasive) for a user to append an argument rather
than edit an entire line. This section will be rewritten and made available in
the next release.

3) The steps are for changing a user account password, not 'root' password.

4)For the purposes of clearing the Red Hat Linux default shell environment, this
shortcut is valid. Since it is written in such a way as to preclude using the
shortcut while running an application within the terminal, I believe the text
should stand as it is.


I thank you again for your report and suggestions. I am considering this bug
closed but if you disagree with any of my findings, you may reopen this bug at
your leisure :)
Comment 3 Miloslav Trmac 2003-04-30 13:38:53 EDT
Hello,

Ah, we have NEXTRELEASE now. Nice.

I'd like to point out that in 16.9 (the 3) ), the heading is:
I *forgot* or want to change my user account password.

The forgot part requires logging in as root.

And BTW, package usermode-gtk (installed by default)
has a GUI password changing frontend. (Settings/Password?)

Thanks.

BTW, Re: that "patience": In my experience, documentation
bugs are responded to far quicker than code bugs. Great work!
Comment 4 John Ha 2003-04-30 14:28:24 EDT
Actually, it is in the GNOME panel Main Menu => Preferences => Password. And,
you're right; the graphical method should be documented as well as the terminal
method. Thank you for the suggestion; it will be incorporated in the NEXTRELEASE
(FYI, our documentation technical lead tfox suggested that new resolution for
bugzilla :)

I will also add instructions to log in as root to change a forgotten user password.

We should be so lucky to have more bug reports like yours :) Thank you very much
for your feedback and for the compliments.

Note You need to log in before you can comment on or make changes to this bug.