Bug 896489 - Network creation without specifying dns is created with default of Google's public DNS
Network creation without specifying dns is created with default of Google's p...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: RHOS Maint
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 07:21 EST by Rami Vaknin
Modified: 2014-01-12 18:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 11:25:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2013-01-17 07:21:01 EST
Version:
Folsom on RHEL6.4
openstack-nova-scheduler-2012.2.2-5.el6ost.noarch
openstack-nova-compute-2012.2.2-5.el6ost.noarch
python-nova-2012.2.2-5.el6ost.noarch
openstack-nova-network-2012.2.2-5.el6ost.noarch
openstack-nova-objectstore-2012.2.2-5.el6ost.noarch
openstack-nova-volume-2012.2.2-5.el6ost.noarch
openstack-nova-2012.2.2-5.el6ost.noarch
python-novaclient-2.10.0-1.el6ost.noarch
openstack-nova-common-2012.2.2-5.el6ost.noarch
openstack-nova-cert-2012.2.2-5.el6ost.noarch
openstack-nova-console-2012.2.2-5.el6ost.noarch
openstack-nova-novncproxy-0.4-2.el6.noarch
openstack-nova-api-2012.2.2-5.el6ost.noarch


Scenario:
Create a network using nova-manage, do not specify dns


Results:
dns1 entry will get Goolge's public DNS address (8.8.4.4).


Expected Results:
dns1 entry should remain empty.


Additional information:

# nova-manage network create --label=rami2 --fixed_range_v4=192.168.11.224/27 --bridge=br100 --project_id=a2d3296b79d74bc5ac647976834b7126 --num_networks=1 --network_size=32
# mysql -u root nova -e "select id,cidr,bridge,dns1,dns2,label from networks;" 
+----+-------------------+--------+---------+------+-------------+
| id | cidr              | bridge | dns1    | dns2 | label       |
+----+-------------------+--------+---------+------+-------------+
|  1 | 192.168.7.0/24    | br100  | 8.8.4.4 | NULL | novanetwork |
|  2 | 192.168.11.224/27 | br100  | 8.8.4.4 | NULL | rami2       |
+----+-------------------+--------+---------+------+-------------+


It looks like the default dns address appears in nova/network/manager.py:

cfg.StrOpt('flat_network_dns',
               default='8.8.4.4',
               help='Dns for simple network'),
Comment 2 Russell Bryant 2013-01-29 11:25:40 EST
I think we should leave this how it is.  It follows the general rule of "default to working".  If someone really doesn't want this to be the default, it can be configured to not have a default, as you have pointed out.

Thanks!
Comment 3 Rami Vaknin 2013-02-03 06:39:28 EST
Do you think it might be better to make it a configuration option (in /etc/nova/nova.conf) instead of hard-coded value? this way an administrator will be able to set its company's DNS server only once instead of adding it as parameter to every network creation.

Note You need to log in before you can comment on or make changes to this bug.